Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14641 closed Bug (invalid)

Translation Missing

Reported by: nidhi Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Instantiate CKEditor in a different language like French
  2. Click on Smiley Toolbarand hover over the icons, translations are missing
  3. Click on Inert Link Toolbar, or Images link Toolbar or Font Color Toolbar and check on "OK" button, translations are missing

Expected result

OK should be translated in french, and smiley's text should also be translated

Actual result

In all the above scenarios none of them is translated

Other details (browser, OS, CKEditor version, installed plugins)

CKEditor version 4.5.5 Installed Plugins: Smiley, Link, Color Button

Change History (4)

comment:1 Changed 3 years ago by nidhi

I am aware that smiley's description can be updated by smiley description config, but shouldn't the descriptions be translated by default?

comment:2 Changed 3 years ago by Jakub Ś

Keywords: Translation Missing removed
Resolution: invalid
Status: newclosed
Version: 4.5.5
  1. I don't think translation for 'OK' is required. This term is known worldwide.
  2. Smileys work in a different fashion. Descriptions for smiles are provided in config.smiley_descriptions option and not in translation files. This is because smiles can be described as e.g. sad or :(. Please see: http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-smiley_descriptions

@nidhik I'm closing this issue as invalid but if you have any arguments for translations of OK and smileys, please add them and we will consider reopening this ticket.

comment:3 Changed 3 years ago by nidhi

Hi I agree, the wiki for "OK" mentions it is a loanword in many languages. Please would you provide other data to support the argument

lets say I do want to translate it, then what would be the recommended approach

Last edited 3 years ago by nidhi (previous) (diff)

comment:4 Changed 3 years ago by Jakub Ś

I'm sorry for late reply.

Since there is no localization approach with the smiles I would recommend using :) :( and so on. Most smiles either speak for themselves or there are some which have their universal shortcuts e.g. rotfl

On one hand we could provide some checking if localized key starting with editor.lang.smiley.... was entered in config.smiley_descriptions (https://github.com/ckeditor/ckeditor-dev/blob/master/plugins/smiley/dialogs/smiley.js#L133-L143) but on the other this could be very troublesome. CKEditor requires localized messages to be present in language files if localized keys are used in code. This means you would have to provide translations for all the languages you support.
Of course you could enter all transaltions in English but this would give the same result as hardcoding English descriptions in config.smiley_descriptions.

One last and most important thing I need to mention. Please remember that you can have any set of smiles used. We don't enforce using any particular set of smileys. The list is open and anyone can add anything there. This argument really supports current approach as the best one (at least this is how we see it).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy