Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14647 closed Bug (invalid)

BBCode output stops working when Wordcount plugin added via CKBuilder

Reported by: Alan Howshall Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Go to CKBuilder with following URL http://ckeditor.com/builder/734cfcca433721a20675475635994d04 and download Optimised version of 4.5.9 with that set of features
  2. Extract unaltered contents of downloaded Zip and open /samples/index.html in a browser.
  3. Make 'Hello world!' sample text into Bold.
  4. Toggle into 'View source' mode.

Expected result

Source code view should output [b] style BBCode tags around Bold formatted content and then correctly re-display Rich Text preview when exiting View source mode.

Actual result

Source code view outputs HTML, instead of BBCode, style tags. Then, because BBCode plugin is still present and partially working, exiting and entering 'View source' causes progressively worse corruption of both Preview and Source code text contents.

Other details (browser, OS, CKEditor version, installed plugins)

This problem does not occur with near identical CKBuilder download of http://ckeditor.com/builder/6e18dbe9776749ca0c98f94ccc0e842f who's only difference is not adding Wordcount plugin. However my project obviously wants all those features including Wordcount!

Incorrect behaviour replicated consistently on Windows 8.1 with Firefox 46, IE11 and Chrome 50. CKEditor version is 4.5.9

Paste of build-config.js from problem CKBuilder download:

/

  • @license Copyright (c) 2003-2016, CKSource - Frederico Knabben. All rights reserved.
  • For licensing, see LICENSE.md or http://ckeditor.com/license */

/

var CKBUILDER_CONFIG = {

skin: 'bootstrapck', preset: 'basic', ignore: [

'.bender', 'bender.js', 'bender-err.log', 'bender-out.log', 'dev', '.DS_Store', '.editorconfig', '.gitattributes', '.gitignore', 'gruntfile.js', '.idea', '.jscsrc', '.jshintignore', '.jshintrc', 'less', '.mailmap', 'node_modules', 'package.json', 'README.md', 'tests'

], plugins : {

'basicstyles' : 1, 'bbcode' : 1, 'clipboard' : 1, 'enterkey' : 1, 'entities' : 1, 'indentlist' : 1, 'list' : 1, 'pastefromword' : 1, 'pastetext' : 1, 'removeformat' : 1, 'sourcearea' : 1, 'toolbar' : 1, 'undo' : 1, 'wordcount' : 1, 'wysiwygarea' : 1

}, languages : {

'en' : 1

}

};

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Component: Project : CKBuilderGeneral
Resolution: invalid
Status: newclosed
Version: 4.5.9

However my project obviously wants all those features including Wordcount!

If it works by deafult but not when WordCount plugin is around then I would suspect the WordCount plugin. Unfortunately it is not a plugin created by CKSource. This is a third-party plugin created by a member of CKSource community. In general if WordCount conflicts with one of CKSource plugins, you should report this to plugin author.

comment:2 Changed 3 years ago by Alan Howshall

Thank you for your feedback, appreciate your position in closing a bug when there was a suspected interaction/problem caused by 3rd party plugin.

For people's future searching reference: I have now been able to reproduce essentially the same problem but with much more minimal plugins selection in CKBuilder, and all with CK Source created plugins. So I have raised that as a separate new ticket http://dev.ckeditor.com/ticket/14658

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy