Opened 11 years ago

Closed 7 years ago

#1468 closed Bug (wontfix)

MediaWiki+FCKeditor doesn't play nicely with HTML lists

Reported by: Tom Lamano Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

MediaWiki+FCKeditor doesn't play nicely with HTML lists. See the following HTML list, where each level of the list uses a different list-style-type:

<ol>

<li>First level, first item</li>

<li>First level, second item

<ol style="list-style-type:lower-alpha">

<li>Second level, first item</li>

<li>Second level, second item</li>

</ol>

<li>First level, third item</li>

</ol>

If MediaWiki+FCKeditor gets its hands on this list, it turns it into the following:

#First level, first item

#First level, second item

##Second level, first item

##Second level, second item

#First level, third item

By converting it into a MediaWiki list, the list-style-type of the second level is lost, so they're all numbers instead of numbers at the top level and letters at the next.

It would be preferable if MediaWiki+FCKeditor would refrain from converting HTML lists to MediaWiki if the HTML lists have styles which will get lost.

Change History (6)

comment:1 Changed 11 years ago by Wojciech Olchawa

Resolution: wontfix
Status: newclosed

Hi! The problem is that the the wiki sytax doesn't allow letters in the lists so it is impossible to create this kind of list e.g.

  1. Lists
    1. bulleted lists
    2. numbered lists

So we unfortunately we can't fix this problem due to wiki syntax limitations which we want FCKeditor to be fully compatible with.

View http://meta.wikimedia.org/wiki/Help:Editing to see the list of available lists :)

comment:2 Changed 11 years ago by Tom Lamano

Resolution: wontfix
Status: closedreopened

I do understand that Wiki syntax doesn't support letters in lists, but MediaWiki does support the use of HTML lists when desired. See http://meta.wikimedia.org/wiki/Help:List which describes the use of HTML lists in MediaWiki.

FCKeditor should not break HTML lists when it encounters them, because according to MediaWiki's own documentation, they are supposed to be supported. It should not attempt to convert HTML lists to Wiki syntax when doing so would lose information.

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: Confimed added

Sorry for the misunderstanding.

My mistake obviously.

Thanks for your information and for investigating this problem.

Confirmed in IE and FF2.

comment:4 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added; Confimed removed

comment:5 Changed 10 years ago by pmck

Wondering if there has been any movement on this issue? I really want to use the Editor but without the ability to break up lists using HTML, I won't be able to use it at all. We are using our wiki for step-by-step documentation that includes screen shots in between numbering and I've just encountered this problem. It has put my wiki production at a standstill! The only solution I can think of in the short term is to completely disable the editor and stop using it.

comment:6 Changed 7 years ago by Krzysztof Studnik

Keywords: Confirmed removed
Resolution: wontfix
Status: reopenedclosed

MediaWiki and FCKeditor are no longer supported. Closing the ticket

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy