Opened 3 years ago

Closed 3 years ago

#14681 closed Bug (duplicate)

Buttons do not work properly when an attribute is added.

Reported by: Ann Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When "id" or any attribute is added to an element (strong,italic,underline), it doesn't work properly i.e. When a style (e.g Bold) is applied using strong (as implemented in Alloy editor). In this case once selection is set to bold and an "id" attribute is appended in the strong tag. Due to this user cannot set selection back to normal style, instead when bold button is clicked another strong tag is added and this behavior continues if button is clicked multiple times. However when style is applied using "span" element this behavior is not observed.

Steps to reproduce

  1. add following in config.js
config.coreStyles_bold =
 {
 element: 'strong',
 overrides: 'b'
 };
  1. Create a div add sample text.
    <div id="container" >
       <strong id="3143435322vn123554759257">Bold</strong>
    </div>
    
  1. Select text and click bold button.

Expected result

Strong tag is removed and font is set to normal.

Actual result

Strong tag is not removed. Font stays bold.

Other details (browser, OS, CKEditor version, installed plugins)

Browser: chrome,
OS: windows 8.1,
CKEditor version: 4.5.8,
Installed plugins: basicstyles

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.10 (GitHub - master)

This is a duplicate of #8369

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy