Opened 3 years ago

Closed 3 years ago

#14713 closed Bug (invalid)

Unable to select combo box items in toolbar with keyboard

Reported by: CASSupport Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Open Demo Page full featured.
  2. Navigate to a combo box e.g. "Font", then activate the combo box. Then press the key "T" to select an item for example "Tahoma".
  3. The focus doesn't go to the item "Tahoma" like expected.

Expected result

It should be possible to select a combo box item with the keyboard.

Actual result

It´s not possible to select a combobox item with the keyboard.

Other details (browser, OS, CKEditor version, installed plugins)

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.10 (GitHub - master)

Fonts or any other combo is accessible by pressing Enter or Space to open it and by arrows to move focus to particular font.

What you have described could be a feature at most but we really don't consider introducing such in the future so I will have to close this ticket as invalid.

If you would like to introduce such feature yourself, you are welcome to provide a pull request and ticket will be reopened.
You would probably need to take first character from font label http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-font_names (Label is what is displayed in combo and is displayed before / -> 'Arial/Arial, Helvetica, sans-serif') and change it into something like keystroke. This would have to be done dynamically because users can have many different fonts. Please also note that there is another syntax -> 'Arial;Times New Roman;Verdana' (you might say these are labels only). This would have to be handled as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy