Opened 3 years ago

Closed 3 years ago

#14737 closed Bug (duplicate)

Replacing an image within CKFinder with the same name is not immediately updated in the Image Properties Window which also does not get updated in the CKEditor window.

Reported by: Murthy Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.11
Keywords: Cc:

Description

I am reporting this from Oracle. Customer reports that replacing an image within CKFinder with the same name is not immediately updated in the Image Properties Window which also does not get updated in the CKEditor

Steps to reproduce

On IE Scenario 1

  1. Insert image image.jpg
  2. Right click on image properties and navigate to browser server
  3. Delete image.jpg
  4. Upload with another file named image.jpg
  5. Double click to select it.
  6. In image properties window the image is not updated
  7. Selecting OK, image is still not updated in CKEditor.
  8. Edit and select image properties note the image is updated
  9. Select ok, image is not displayed
  10. Reload the CKEditor image is displayed properly.

Scenario 2

  1. Insert image image.jpg
  2. right click on image properties navigate to browser server
  3. delete image.jpg
  4. replace with another file named image.jpg
  5. double click
  6. In image properties window the image is not updated
  7. Selecting OK image is still not displayed
  8. Select Image Properties again and note that the image is corrctly updated in Preview
  9. Select ok image is not displayed
  10. Reload the CKEditor, image is displayed properly

On Firefox Scenario 3

  1. Insert image image.jpg
  2. right click on image properties
  3. navigate to browser server
  4. delete image.jpg
  5. replace with another file named image.jpg
  6. double click
  7. In image properties window the image is not updated
  8. Selecting OK displays the correct image

Expected result

Once the image is replaced it should be immediately updated in the Preview and CKEditor window.

Actual result

Replacing an image within CKFinder with the same name is not immediately updated in the Image Properties Window and CKEditor window.

Other details (browser, OS, CKEditor version, installed plugins)

This was tested on CKEditor 4.4.7 (revision 3a35b3d) and ckfinder-2.4.2 This happen in all browsers(IE, Mozilla and Firefox) with slight different in behavior in Firefox as mentioned in Scenario 3

Please let us know if this can be fixed.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This is a duplicate of #9026

@murthy.krishnappa I have added Oracle keyword to #9026 and forwarded that ticket to the team.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy