Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14740 closed Bug (duplicate)

[IE] font-family quotes get replaced with entities

Reported by: Tade0 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Tade0)

Steps to reproduce

  1. Open http://tests.ckeditor.dev/tests/plugins/font/manual/quotedfont in IE.
  2. Switch to source mode.

Expected result

The second line of the source should read: <p><span style="font-family:'Univers LT Std',sans-serif">This is styled part.</span></p>

Actual result

The second line of the source reads: <p><span style="font-family:&quot;Univers LT Std&quot;,sans-serif">This is styled part.</span></p>

Other details (browser, OS, CKEditor version, installed plugins)

IE11, IE10

Both forms work. The issue here is for them to be the same.

Change History (4)

comment:1 Changed 3 years ago by Tade0

Description: modified (diff)

comment:2 Changed 3 years ago by Marek Lewandowski

Status: newconfirmed

comment:3 Changed 3 years ago by Marek Lewandowski

Summary: IE source not consistent with sources from other browsers.[IE] font-family quotes get replaced with entities

comment:4 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed
Version: 4.5.10 (GitHub - master)

This is in fact a duplicate of an old issue #7352.

Last edited 3 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy