Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14756 closed Bug (invalid)

Separators after combo buttons

Reported by: Mark Wade Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Use a skin which does not visually separate combo boxes from the rest of the toolbar, for example, minimalist.
  2. Set the toolbar configuration to have a separator (i.e. "-") immediately after a combo button, such as FontSize.

Expected result

A separator displays after the combo button.

Actual result

The separator does not display.

Other details (browser, OS, CKEditor version, installed plugins)

Skins such as moono always pull combo buttons out of the rest of the toolbar as if a separator had been placed either side, which could also be seen as incorrect.

Change History (3)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.10 (GitHub - master)

Separators are put between buttons placed in a single group (small bar having few button inside). Dropdowns are displayed as single buttons (this is by design) so separators won't work there as they would have to be placed directly on toolbar and not in a group.

comment:2 Changed 3 years ago by Mark Wade

Shouldn't they always have separators then?

comment:3 Changed 3 years ago by Jakub Ś

No, because there is no need to separate standalone button which is not placed inside a group panel. Dropdown is like standalone button.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy