Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14773 closed Bug (duplicate)

[FF: ] style button switching on and off when user repeatedly click on an empty editor

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: Irina

Description

Steps to reproduce

  1. Open nighty build and empty it's contents
  1. Click on "Bold" icon in toolbar.
  1. Click in Editor body( which is empty).

Issue: see "Bold" button goes off.

  1. Keep clicking in Editor body, repeatedly.

Issue: you will see "Bold" button goes on and off, on and off.

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.10 (GitHub - master)

This is a duplicate of #12634.

When you click repeatedly the result is the same as clicking on a word in text. Like word gets selected, the strong element gets selected. That is why you can see bold being activated on the toolbar. When you start typing text will be normal which is expected - typing on selected content removes that content.

It all comes down to placing caret in empty inline styles.

comment:2 Changed 3 years ago by Tim Liu

thanks for the explanation, it sounds reasonable. close this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy