Opened 3 years ago

Closed 3 years ago

#14787 closed Bug (duplicate)

Permission denied to access property 'nodeType'

Reported by: ramya Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version:
Keywords: Cc: ramya.bojanala@…

Description

Steps to reproduce

  1. Just started using ckeditor and got a little problem. On a button click outside the editor a tag is generated and then inserted into the ckeditor using the following code:

CKEDITOR.instancespageContent?.insertHtml('<cke:video id="video-' + i + '" class="video" src="' + $(this).siblings('.mediaName').text() + '">Video</cke:video>');

  1. The above works fine. The tag is inserted into the editor and it shows the text "Video" in the wysiwyg view. When you click source it shows the tag code as shown below.

<video class="video" id="video-29" src="/link/to/file.flv">Video</video>

  1. Then when you start to click around video element in the editor adding more content the console throws the error:

Permission denied to access property 'nodeType'

Expected result

Actual result

Other details (browser, OS, CKEditor version, installed plugins) == Im using Firefox 44.0b1, Windows 7 Enterprise , CK Editor 4.0

Change History (2)

comment:1 Changed 3 years ago by ramya

Cc: ramya.bojanala@… added

comment:2 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.10 (GitHub - master)

This issue is a duplicate of #12623.

In general native support for video tag or placeholder (like for iframe or flash) should be provided. You could try one of media plugins in our add-ons repository but from what I can see none is working with local video tags - http://ckeditor.com/addons/search/plugins/video.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy