Opened 13 years ago

Closed 12 years ago

#148 closed Bug (wontfix)

Empty DIV

Reported by: jodanbenson@… Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.4
Keywords: Pending Cc:

Description

I have had this problem more than once with FCKeditor v2.4:

I load a page that includes very basic content. For example, if viewing the source:

<b>Heading</b><br />
<p>This is the first paragraph</p>

Back on the WYSIWYG side, if I remove the formatting from the "Heading", and then reformat it to a "h1" (defined in the external .xml and .css files) from the Style combo box, then center the H1 text, the following is the result of the source:

<div align="center">&nbsp;</div>
<h1 align="center">Heading</h1>
<p>This is the first paragraph</p>

It's adding an empty DIV, which is most of the time not removable (without source code access).

Change History (3)

comment:1 Changed 13 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles
Keywords: div empty h1 heading removed
Version: FCKeditor 2.4

I was not able to reproduce it. Can you provide a precise step by step, so we have the same results?

I strongly believe that the re-work of the style combo for v 2.5 will be fixing this one.

comment:2 Changed 13 years ago by Frederico Caldeira Knabben

Keywords: Pending added

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: wontfix
Status: newclosed

Expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy