Opened 3 years ago

Closed 2 years ago

#14826 closed Bug (worksforme)

[Edge] Cannot focus widget programmatically at the first try.

Reported by: kkrzton Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by kkrzton)

The parent task is #14819.

Steps to reproduce

  1. Go to http://ckeditor.com/demo#widgets.
  2. Run var editor = CKEDITOR.instances.editor2;editor.widgets.getByElement( editor.editable().findOne( 'pre' ) ).focus(); from the console without focusing the editor.

Expected result

The first code snippet widget in the second editor should be focused.

Actual result

The focus/caret is placed on the beginning of the second editor content.

When code is run for the second time or if the editor was focused earlier everything works as expected.

Other details (browser, OS, CKEditor version, installed plugins)

Edge (Edge 38.14393, EdgeHTML 14.14393)

This issue causes some unit tests fails in tests/plugins/image2/acf and probably in tests/plugins/image2/justify and tests/plugins/widget/widgetselection.

Change History (5)

comment:1 Changed 3 years ago by kkrzton

Status: newconfirmed

comment:2 Changed 3 years ago by kkrzton

Description: modified (diff)

comment:3 Changed 2 years ago by kkrzton

Status: confirmedpending

The up to date scenario is:

  1. Go to http://sdk.ckeditor.com/samples/codesnippet.html.
  2. Run var editor = CKEDITOR.instances.editor1;editor.widgets.getByElement( editor.editable().findOne( 'pre' ) ).focus(); from the console without focusing the editor.

However, I am not able to reproduce this issue (same version of Edge (Edge 38.14393, EdgeHTML 14.14393)). Can I ask someone to also recheck the issue. If it is not reproducible we may close it.

comment:4 Changed 2 years ago by Jakub Ś

I have tried with 2 editors in Microsoft Edge 38.14393.0.0 (Microsoft EdgeHTML 14.14393) but it has worked as expected. The first widget in second editor was focused.

comment:5 Changed 2 years ago by kkrzton

Resolution: worksforme
Status: pendingclosed

Looks like it was fixed by some Edge update.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy