Opened 3 years ago

Closed 3 years ago

#14834 closed New Feature (invalid)

Setting to retain br tags before block elements when switching to source mode

Reported by: Praveen Peri Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Add a br element before a block element like a div or p in wyswig
  2. Switch to source and notice that br tag is yanked out and replaced with nbsp;

Expected result

An overridable config setting that can prevent this from happening

Actual result

Doesn't seem overridable

Other details (browser, OS, CKEditor version, installed plugins)

To be more clear, this is happening in cleanBogus() inside htmlDataProcessor.js

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.10 (GitHub - master)

This feature request is IMO a duplicate of a bug #11392. You can also see #10146 to get the full story behind the issue.

There is a workaround attached in http://dev.ckeditor.com/ticket/10146#comment:34. It works for most cases mentioned in these two tickets and in this one.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy