Opened 3 years ago

Closed 3 years ago

#14843 closed Bug (invalid)

Cannot use download.ckeditor.com over SSL

Reported by: mpdude Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

While the CKE "main" download (e. g. http://download.cksource.com/CKEditor/CKEditor/CKEditor%204.5.10/ckeditor_4.5.10_standard.zip) also works over SSL, many plugins (like http://ckeditor.com/addon/language) are hosted on http://download.ckeditor.com.

One cannot simply edit these links to use HTTPS, because the SSL certificate only provides "host3.cksource.com" as CN.

Especially when downloading such plugins using Composer, HTTPS support would be helpful.

Steps to reproduce

curl https://download.ckeditor.com/language/releases/language_4.5.10.zip > /dev/null

Expected result

Successful download.

Actual result

curl: (51) SSL: no alternative certificate subject name matches target host name 'download.ckeditor.com'

Other details (browser, OS, CKEditor version, installed plugins)

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.10 (GitHub - master)

Thank you for the report however this is not a CKEditor bug but CKSource website problem. I'm closing this ticket here and moving it to our internal bug tracker for websites.

Thank you.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy