Opened 14 months ago

Closed 9 months ago

#14912 closed Bug (duplicate)

Paste should match style of target context when forcePasteAsPlainText is enabled

Reported by: vdk9000 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Download standard package from http://ckeditor.com/download
  2. Add to config.js: config.forcePasteAsPlainText = true;
  3. Open samples/index.html in browser
  4. Bold the entire paragraph "I'm an instance of CKEditor"
  5. Select and copy the text "Congratulations!"
  6. Click inside the bolded paragraph and press CMD+V (Mac) to paste

Expected result

Pasted text should match the style of the target context (i.e. bold text), since the text is without formatting of it's own (plain text).

Actual result

Pasted text does not respect the formatting of it's new context. The bold element is split up into two at the position of paste.

Other details (browser, OS, CKEditor version, installed plugins)

  • Mac OS X 10.9.4
  • Google Chrome 53.0.2785.116 (64-bit)
  • CKEditor 4.5.11 (revision 3876e73)
  • Standard plugins

Attachments (1)

Näyttökuva 2016-10-7 kello 14.08.12.png (49.8 KB) - added by vdk9000 14 months ago.
The result

Download all attachments as: .zip

Change History (3)

Changed 14 months ago by vdk9000

The result

comment:1 Changed 14 months ago by vdk9000

Summary: When using forcePasteAsPlainText it should match style of target contextPaste should match style of target context when forcePasteAsPlainText is enabled

comment:2 Changed 9 months ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.11

This is a duplicate of #16454.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy