Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#150 closed Bug (worksforme)

flash embed properties not saved

Reported by: area51@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: WorksForMe Pending Cc:

Description

When adding a flash movie, and editing the "Auto play", "repeat", "enable menu" and "style" options in the Advanced tab (unchecking all checkboxes, and filling in all fields), it is initially saved when you save it to a file, and the Flash movie works as expected.

After editing the file again these settings are back to default (checkboxes are
checked again, Stlye textbox is empty.

Does not apply to "ID", "Stylesheet class", "Title" and "Scale information" as this
information is shown as filled in the first time.

Attachments (7)

1.jpg (155.2 KB) - added by area51@… 12 years ago.
Step 1
2.jpg (192.0 KB) - added by area51@… 12 years ago.
Step 2
3.jpg (127.0 KB) - added by area51@… 12 years ago.
Step 3
4.jpg (192.3 KB) - added by area51@… 12 years ago.
Step 4
5.jpg (153.5 KB) - added by area51@… 12 years ago.
Step 5
6.jpg (179.3 KB) - added by area51@… 12 years ago.
Step 6
test_flash.html (2.2 KB) - added by Frederico Caldeira Knabben 12 years ago.
Test Case

Download all attachments as: .zip

Change History (17)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe Pending added

I was not able to reproduce the problem. Tested with IE6 and FF2.

Please more info so we can investigate it better.

Changed 12 years ago by area51@…

Attachment: 1.jpg added

Step 1

Changed 12 years ago by area51@…

Attachment: 2.jpg added

Step 2

Changed 12 years ago by area51@…

Attachment: 3.jpg added

Step 3

Changed 12 years ago by area51@…

Attachment: 4.jpg added

Step 4

Changed 12 years ago by area51@…

Attachment: 5.jpg added

Step 5

Changed 12 years ago by area51@…

Attachment: 6.jpg added

Step 6

comment:2 Changed 12 years ago by area51@…

a few images to make it clear Step 1 I have a normal page, which i can edit by clicking the Edit button, circled red.

Step 2 Page looks exactly as it does in normal mode.

Step 3 I click the "Add Flash" button, and select a file named titel.swf. I added a custom box which is used for the Flashvars option to add variables into flash. I added a 'fake' "Update" button to make onblur occur, since not everybody knows that they have to 'unfocus' the textbox to see a preview. In the Advanced tab, i uncheck all boxes, select "No border", and fill in all fields as an example, and click Ok.

Step 4 The Flash object is shown in the editor, and i click "Save", circled red. Note: When opening the Flash properties at this state, all settings are still there as in image 3.

Step 5 The page looks exactly as expected.

Step 6 However, if i click the edit button again, and i open the properties of the Flash object, my custom field is empty, but when clicking the Advanced tab, i see all the checkboxes are checked again, and the Style box is empty aswell.

When looking at the source in the editor, by clicking the "source" button, some properties are gone.

I hope this step by step helps.

comment:3 Changed 12 years ago by area51@…

Additional info: I've downloaded the latest version of FCKEditor (2.4). I'm using an Apache server with PHP under Windows XP Pro SP2. CPU: Intel Core Duo notebook with 2GB Ram.

Changed 12 years ago by Frederico Caldeira Knabben

Attachment: test_flash.html added

Test Case

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

I've just attached the test page I'm using for it. The HTML used in the value has been generated with FCKeditor. I would ask you to copy this file in the _samples/html folder and try it. You may change the swf path to something in your system.

It worked well for me with IE6.

Let us know the results.

comment:5 in reply to:  4 Changed 12 years ago by anonymous

The example file is working for the Style property, and so is the editor I am using. Though, the checkboxes are still checked, while in the code everything is set to false, even in the example file posted here (attachment:test_flash.html). Also, when any other properties are manually added in the code window of fckeditor, saved, and edited again, they are gone aswell.

To be short: only the properties that can be entered in the Flash Properties window, are saved, except the checkbox properties:

  • autoplay
  • repeat
  • menu

and custom properties are ignored when opening an existing file. I've created a video to show what I exactly do. I hope it's clear enough.

Video

comment:6 Changed 12 years ago by Frederico Caldeira Knabben

Have you checked the contents of your database after save? Have you also checked your editor page source to see that the changed values are really there before loading then to the editor?

I have the impression that the changes are not being saved at all.

comment:7 Changed 12 years ago by Alfonso Martínez de Lizarrondo

This is a WorksForMe using the nightlies, I think that it was fixed in [143]

comment:8 Changed 12 years ago by ar34z

After editing and saving the file in FCK Editor, the source looks like this:

<embed class="class_flash" id="kop_titel" title="title_for_flash" style="margin: 0px" src="/flash/titel.swf" width="600" height="32" scale="noborder" type="application/x-shockwave-flash" flashvars="koptekst=Custom title" play="false" loop="false" menu="false"></embed>

I have unchecked those checkboxes, and filled in my custom title textfield. Also custom stylesheet, title, ID and classname are saved.

After clikcing the Edit Page button, I open the source of the page, and I see in the a hidden textfield with the name I gave it in PHP (editor_content)"

<input type="hidden" id="editor_content" name="editor_content" value="&lt;table class=&quot;hometable&quot; cellspacing=&quot;0&quot; cellpadding=&quot;0&quot;&gt;
    &lt;tbody&gt;
        &lt;tr&gt;
            &lt;td colspan=&quot;2&quot;&gt;&lt;embed class=&quot;class_flash&quot; id=&quot;kop_titel&quot; title=&quot;title_for_flash&quot; style=&quot;margin: 0px&quot; src=&quot;/flash/titel.swf&quot; width=&quot;600&quot; height=&quot;32&quot; scale=&quot;noborder&quot; type=&quot;application/x-shockwave-flash&quot; flashvars=&quot;koptekst=Custom title&quot; play=&quot;true&quot; loop=&quot;true&quot; menu=&quot;true&quot;&gt;&lt;/embed&gt;&lt;/td&gt;
        &lt;/tr&gt;
        &lt;tr&gt;
            &lt;td class=&quot;hometable_txt&quot;&gt;
            &lt;p&gt;
              [...]
            &lt;/td&gt;
            &lt;td class=&quot;ads&quot;&gt;&lt;?include(&quot;ads/$lang.php&quot;);?&gt;&lt;/td&gt;
        &lt;/tr&gt;
    &lt;/tbody&gt;
&lt;/table&gt;" style="display:none" />

It contains the whole page including flash object with HTML characters stripped, but the code is still readable. It looks like the embed still has all the properties filled in correctly:

&lt;embed class=&quot;class_flash&quot; id=&quot;kop_titel&quot; title=&quot;title_for_flash&quot; style=&quot;margin: 0px&quot; src=&quot;/flash/titel.swf&quot; width=&quot;600&quot; height=&quot;32&quot; scale=&quot;noborder&quot; type=&quot;application/x-shockwave-flash&quot; flashvars=&quot;koptekst=Custom title&quot; play=&quot;false&quot; loop=&quot;false&quot; menu=&quot;false&quot;&gt;&lt;/embed&gt;&lt;/td&gt;

As in the normal HTML, the properties are:

class=&quot;class_flash&quot;
id=&quot;kop_titel&quot;
title=&quot;title_for_flash&quot;
style=&quot;margin: 0px&quot;
play=&quot;false&quot;
loop=&quot;false&quot;
menu=&quot;false&quot;

So the settings are being saved, but when loading the FCK Editor wants to load its properties, it seems not all of them can be loaded.

comment:9 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Did you check with 2.4.1 or 2.4.2 ?

Those releases had the [143] patch

comment:10 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

Expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy