Opened 12 years ago

Closed 12 years ago

#1570 closed Bug (invalid)

Replace tab of Find/Replace dialog can crash IE7

Reported by: Mark Bryson Owned by:
Priority: Normal Milestone: FCKeditor 2.5
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Pending Cc:

Description

Only IE7 and nightly build of 11/26/07 tested.

Can be reproduced by:

  1. Going to http://www.fckeditor.net/nightly/fckeditor/_samples/default.html
  1. Replace text with: one two three one two three one two three
  1. Put carrot at the beginning and select the replace dialog.
  1. In the "Find what" field of the "Replace" tab, type 'one' leaving the "Replace with" field blank for replacing with nothing.
  1. Press 'Replace' button several times, or 'Replace All' button only once.

The first replacement works. It crashes within the next couple replacements wanting to tell Microsoft about it.

Change History (3)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Pending added

I'm not able to reproduce it here with the current nightly. Could you clear your browser's cache and try it again? Does it happens always or randomly?

Can anyone else reproduce it?

comment:2 Changed 12 years ago by Mark Bryson

It did originally happen every time about three times with the nightly, and every time when tried from my own LAMP server. After cleaning cache and a client reboot (winXP), I couldn't reproduce it either! Sorry for not suspecting my system first, but this dialog was ALL that wasn't working right for me.

comment:3 Changed 12 years ago by Martin Kou

Resolution: invalid
Status: newclosed

So it seems it isn't the editor's fault in this case. Closing ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy