Opened 10 years ago

Closed 9 years ago

#1593 closed Bug (fixed)

IE: The sampleposteddata pages are not wrapping the "Value" collumn

Reported by: Frederico Caldeira Knabben Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.6.1
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

Steps to Reproduce

  1. Load the following HTML in sample01.html:
<p>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Vivamus id ipsum
blandit quam sagittis varius. Sed ipsum metus, lobortis sodales, congue quis,
interdum quis, risus. Duis aliquet, ante sed fermentum pulvinar, sem nibh
vulputate pede, sed accumsan odio elit sed libero.</p>
  1. Switch to WYSIWYG.
  2. Submit the form.

The text will be shown all in one line in IE. In FF, Safari and Opera it will wrap properly.

Attachments (5)

1593.patch (2.0 KB) - added by Wojciech Olchawa 10 years ago.
Patch proposal
1593_2.patch (2.3 KB) - added by Wojciech Olchawa 10 years ago.
Patch proposal
1593_3.2.patch (3.9 KB) - added by Alfonso Martínez de Lizarrondo 10 years ago.
New patch
1593_4.patch (10.9 KB) - added by Alfonso Martínez de Lizarrondo 9 years ago.
Revised patch
1593_5.patch (11.5 KB) - added by Alfonso Martínez de Lizarrondo 9 years ago.
Revised patch

Download all attachments as: .zip

Change History (26)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6FCKeditor 2.6.1

comment:3 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:4 Changed 10 years ago by Martin Kou

Using IE6 on the client side and IIS5.1/WinXP on the server side, sampleposteddata.asp doesn't even seem to work (i.e. no output). Strangely, using Firefox on the client side instead works.

I'm not sure if I've got some settings messed up.

comment:5 Changed 10 years ago by Martin Kou

Owner: Martin Kou deleted
Status: assignednew

comment:6 Changed 10 years ago by Wojciech Olchawa

I've done some tests and I have exactly opposit results. FF doesn't wrap the text and IE does. Tested using FCKeditor SVN

comment:7 Changed 10 years ago by Wojciech Olchawa

Owner: set to Wojciech Olchawa

comment:8 Changed 10 years ago by Wojciech Olchawa

Keywords: Review? added

comment:9 Changed 10 years ago by Wojciech Olchawa

Keywords: Review? removed

Changed 10 years ago by Wojciech Olchawa

Attachment: 1593.patch added

Patch proposal

comment:10 Changed 10 years ago by Wojciech Olchawa

Keywords: Review? added

comment:11 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed

It's interesting to note that all the three files output a different HTML. I would prefer to change all of them to this kind of structure:

<table id="sampleOutput">
	<thead>
		<tr>
			<th>Field Name</th>
			<th>Value</th>
		</tr>
	</thead>
	<tbody>

	<% For Each sForm in Request.Form %>
	<tr>
		<th><%=sForm%></th>
		<td><%=Server.HTMLEncode( Request.Form(sForm) )%></td>
	</tr>

	<% Next %>
	</tbody>
</table>

and put all the styles in the sample.css file.

Of course, now in the html folder the file is the php version, not the asp.

Changed 10 years ago by Wojciech Olchawa

Attachment: 1593_2.patch added

Patch proposal

comment:12 Changed 10 years ago by Wojciech Olchawa

Keywords: Review? added; Review- removed

comment:13 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review- added; Review? removed
Owner: changed from Wojciech Olchawa to Alfonso Martínez de Lizarrondo

the rules in CSS for td has an invalid value.

And while I'm testing this, I can't see the output in the php page, I'm gonna attach a patch that fixes the problem, and my previous suggestion.

Changed 10 years ago by Alfonso Martínez de Lizarrondo

Attachment: 1593_3.2.patch added

New patch

comment:14 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added; Review- removed

comment:15 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

There is a lot of confusion here... this ticket has been opened when we were using an ASP page to show the posted data for the HTML samples (see it here). Now that we are using the PHP page, this ticket is not anymore valid, because I thought all server side integrations were using the same system. But they are not. Actually, the HTML correctly wraps today with the HTML samples.

The original ASP page has one important difference, that I expect to have in all implementations. It uses a <pre> to properly display the data. It means that white spaces and line breaks are correctly displayed.

So, the fix for this ticket is much broader. It must still propose a <pre> or anything similar, but also properly wrap the text. Actually, the we need the exact same output on all integration files.

Also, the patch must include the fix for all our server side integration files, not only ASP and PHP.

comment:16 Changed 9 years ago by Frederico Caldeira Knabben

The solution at "Formatting quoted code in blog posts" may be handy.

Changed 9 years ago by Alfonso Martínez de Lizarrondo

Attachment: 1593_4.patch added

Revised patch

comment:17 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added; Review- removed

I've modified the css for the pre element and added it to all the samples, as well as cleaning up the inline styles and attributes that were being used.

I just hope that all the samples keep on working, I'm unable to test them myself.

comment:18 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

No lucky... it is not yet wrapping in IE. It looks good with FF and Safari.

Also, is there any chance of having the Field Name vertically aligned at the top? It may disappear for long data.

Changed 9 years ago by Alfonso Martínez de Lizarrondo

Attachment: 1593_5.patch added

Revised patch

comment:19 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added; Review- removed

It seems that the problem was that IE was automatically expanding the width of the table, so I've forced it to keep the widths.

The alignments have been changed in the css file.

I've noted in the what's new that this patch also fixes #2239

comment:20 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:21 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: newclosed

fixed with [2039]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy