Opened 11 years ago

Closed 6 years ago

#1623 closed Bug (fixed)

Removing Bold, Italic, Underline, Striketrough and maybe more is buggy/counterintuitive in Firefox

Reported by: bongobongo Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.5
Keywords: FireFox Cc:

Description (last modified by Frederico Caldeira Knabben)

Hi.

Done some more tests in version 2.5 and found this: Also tested on the demo on www.fckeditor.net

In Firefox:

  1. Enter some text in the editor.
  2. Select the text and then click Bold, Italic, Underline, or Striketrough button
  3. Select something else in the editor than the selected text or just give focus to something else in the page or editor.
  4. Select the same text again that you previously applied the Bold, Italic ... or whatever.
  5. If you now in #2 clicked Bold button, then you will now have to click the bold button TWICE to remove Bold from the text.

If you only place the cursor somewhere in the text that is bold without selecting anything, then one click on the Bold will remove it.

I find this very little intuitive. I do not mind that one can just place cursor within text and the click the button to remove previously applied Bold or whatever. But the fact that you cannot actively select same text as you selected before applying e.g. bold, in order to remove it just counterintuitive.

In IE6 (only tested in IE6 and Firefox 2.0.0.11), selecting the same text one previously applied the Bold to in order to remove it, and then clicking Bold button will remove it with only one click.

I have only tested Bold, Italic, Underline and Striketrhough, Subscript and Superscript buttons... This may allso be an issue with some of the other buttons as well


Also found an anomality with Remove link button in Firefox:

  1. Enter some lines of text in the editor.
  2. Select a line of text.
  3. Clik the Insert/Edit link button and insert a link for the selected text.
  4. Click somewhere else in the editor to deselect the text.
  5. Click somewhere in the link once, or select whole text or a part of the link (do NOT doubleclick to select the link (text)). You should now see that the Remove link button is enabled which is as expected.
  1. Click somewhere else in the editor to deselect the text.
  2. Double click somewhere in the link to select the link text. Now the Remove link button is not enabled.

Change History (9)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Description: modified (diff)

bongobongo, I would ask you to please open separated tickets for each issue. It is quite difficult to follow different bugs in the same ticket.

Thanks anyway for your findings.

comment:2 Changed 11 years ago by bongobongo

Hi.

I belive the issues are related.

I also belive I was giving a little confusing information about how the anomalities regarding Bold, Italic ... etc buttons behaved. Sorry about that.

When selecting (without doubleclick) text that has previously been applied e.g. B tag using the Bold button then the Bold button will work as expected in Firefox... the bold is removed by clicking the bold button ONCE.

But when doubleclicking the bold text and then trying to click the Bold button to remove the B tag, then you will have to click TWICE.

The above applies to Firefox (I was using 2.0.0.11)

Hope that clarifies it.... if you still want me to split this into multiple tickets....

comment:3 Changed 11 years ago by bongobongo

Hi again.

The below is tested in Firefox 2.0.0.11 on WinXP. I have also done some quick tests in latest Br. from Opera and found it buggy there to.

It seem to me this is a "generic" bug.

Do you really want me to file a bug for each of these buttons?

Bold, Italic, Underline, Strikethrough, Subscript, Superscript

The bug is still there for all these buttons:

Example (again):

  1. Write a line with more than one word. e.g. FCKeditor is the coolest editor
  2. Doubleclick somewhere in the text in order to select all text.
  3. Click e.g. Bold to make the text bold. Or click any of the other buttons mentioned above.

Now, if you clicked bold, the whole line should now be bold.

If you now, make sure the text is not selected, TRIPPLECLICK somewhere inside the text (on the line or whatever) to select all text in line then you should see that the bold button is not highlighted, which I belive it should be.

Deselect the text again. If you now DOUBLECLICK on any of the words in the line to select the word, then the bold button is now highlighted, which I belive is correct.

If you DOUBLECLICK the first word in the line then the bold button is not highlighted, which is wrong.

If you use the mouse to click and drag to select all the text or some of the words (also the first word) in the line then the bold button is highlighted as it should be.

I really do not see any reason for me to write 5 or more different bugreports for this bug since it occurs to me that these bugs are related.

If you still want one bugreport for each button affected (the bug might affect more than just the five button I mention here), then I suggest one from your devteam do this.

Now I hope this bug can be fixed as soon as possible.

Thanks for the best editor out there!

Best regards

comment:4 Changed 11 years ago by bongobongo

Just a small correction to my newly added post a few minutes ago:

In this text:

  1. Doubleclick somewhere in the text in order to select all text.

Doubleclick should be replaced with TRIPLECLICK.

Just to avoid some possible headace :-)

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles

Thanks for coming with further information on this.

My previous request for separate bug reports was not to open a separated ticket for each formatting button, as those are related to the same problem.

If you look at your original bug report you will find two different bugs reported: the format removal with a collapsed selection, and the incorrect Remove Link behavior.

We'll be discussing the details of your findings later. Thanks!

comment:6 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed FF added

comment:7 Changed 11 years ago by Julia

I'm interested too. (If this bug really corresponds to my problem, I will give details too as soon as possible)!

comment:8 Changed 11 years ago by bongobongo

I see this is not fixed in latest version (2.6) released april 7.

Was it just forgotten or in the priority list?

Hope this can be fixed sooner than laiter though?

comment:9 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I couldn't reproduce any of the issues described any in this ticket. I guess it expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy