Opened 3 years ago

Closed 3 years ago

#16339 closed Bug (invalid)

Can't copy and paste in IE

Reported by: Marwa Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: marwa.raafat.rezk@…

Description

Steps to reproduce

  1. I copy some text from anywhere
  2. try to paste it in the textbox using keyboard short cut (ctrl+v)

Expected result

paste it normaly

Actual result

it do nothing , you can paste only by right click-> paste

Other details (browser, OS, CKEditor version, installed plugins)

i got the following error SCRIPT16389: Unspecified error. File: ckeditor.js, Line: 110, Column: 1511

Attachments (2)

Screenshot 2016-10-18 17.06.45.png (164.6 KB) - added by Marwa 3 years ago.
error 1
Screenshot 2016-10-18 17.06.55.png (115.9 KB) - added by Marwa 3 years ago.
error 2

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Marwa

error 1

Changed 3 years ago by Marwa

error 2

comment:1 Changed 3 years ago by Marwa

Cc: marwa.raafat.rezk@… added

the issue appears with IE only.

comment:2 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I can't confirm your findings. I have copied text/HTML from few different sources and pasted it into CKEditor running in IE11 and Edge. Both worked as expected. You can even check this on our demo page - http://ckeditor.com/demo.

From what I can see you are using dev-tools to emulate IE8. This is not the right way to test CKEditor. You should rather use real IE8 instead. As you can see emulation does poor job because browser is being recognized as IE11 but because it emulates IE8 you get message that addEventListener is not supported (and it isn't in IE8).

Please don't use dev-tools to test how CKEditor works in older IE's.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy