Opened 12 years ago

Closed 11 years ago

#1638 closed Bug (duplicate)

fckstyles.xml: Non-classed div gets all div-styles

Reported by: Brjánn Ljótsson Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version:
Keywords: Cc:

Description

I'm using fckstyles.xml to enable the user to select custom div-classes. Problem is that a div without a class attributes i marked as having all div-styles in the custom styles combo.

Reproduce:

fckstyles.xml <?xml version="1.0" encoding="utf-8" ?> <Styles>

<Style name="Example1" element="div">

<Attribute name="class" value="example" />

</Style> <Style name="Example2" element="div">

<Attribute name="class" value="example2" />

</Style>

</Styles>

HTML: <div>No class</div> <div class="example1">Example1</div> <div class="example2">Example2</div>

"No class" will have both styles selected in the combo, while the other two will have the respective div selected.

Since it is not possible to unselect either style for "No class", nor give it any of the two styles, this makes it impossible to format <div>-tags using the combo.

Change History (2)

comment:1 Changed 12 years ago by Brjánn Ljótsson

Btw, this bug is not present in 2.4.3

comment:2 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Priority: HighNormal
Resolution: duplicate
Status: newclosed

dup of #1503

You'll be able to specify class="" and it will work the way you want.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy