Opened 3 years ago

Closed 3 years ago

#16644 closed Task (fixed)

Make it easier for users to learn on how to style widgets

Reported by: Wiktor Walc Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.6.0
Component: Documentation & Samples Version:
Keywords: Cc:

Description

I just spend a good 5 minutes (knowing where to search more or less) to find how am I supposed to define styles for widgets.

Suggestion:

Change History (6)

comment:1 Changed 3 years ago by Anna Tomanek

Milestone: CKEditor 4.6.0
Status: newconfirmed

comment:2 Changed 3 years ago by Tade0

Owner: set to Tade0
Status: confirmedreview

Added some new styles. Changes pushed to branch:t/16644.

comment:3 Changed 3 years ago by kkrzton

Overall it looks good.

I noticed one issue - when you have widget focused and apply/remove widget style the combo value (in closed state) does not update. It updates only after refocusing widget. However, this is not caused by the changes made for this task, but rather by the way stylescombo detects style changes and updates itself. Separate issue for this should be created.

I will ask @wwalc to validate the styles (from the user perspective as he requested it). If it is ok, I will merge it to the major.

comment:4 Changed 3 years ago by kkrzton

Pushed changes to t/16644.

comment:5 Changed 3 years ago by Tomasz Jakut

Status: reviewreview_passed

LGTM.

comment:6 Changed 3 years ago by kkrzton

Resolution: fixed
Status: review_passedclosed

Merged to major with fbe67fa.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy