Opened 2 years ago

Closed 2 years ago

#16728 closed Bug (fixed)

[QM] Editor is broken once Copy Formatting is added

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.6.2
Component: General Version: 4.6.0
Keywords: Cc:

Description (last modified by Marek Lewandowski)

  1. With IE in Quirks Mode open an editor with copy formatting, e.g. simply samples page.

Expected:

Editor gets loaded.

Actual:

An exception is thrown Object doesn't support this property or method.


The problem is caused by this line. Simply there's no underlying querySelectorAll method in QM.

It can be avoided by simply changing function to the following:

_getScreenReaderContainer: function() {
	if ( CKEDITOR.env.ie6Compat ) {
		// findOne is not supported on Quirks.
		return null;
	}

	return CKEDITOR.document.getBody().findOne( '.cke_copyformatting_notification div[aria-live]' );
}

Change History (6)

comment:1 Changed 2 years ago by Marek Lewandowski

Status: newconfirmed

comment:2 Changed 2 years ago by Marek Lewandowski

Description: modified (diff)

comment:3 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.1CKEditor 4.6.2

comment:4 Changed 2 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:5 Changed 2 years ago by Marek Lewandowski

Status: assignedreview

Pushed to branch:t/16728 - didn't add a manual test since this bug can be reproduced virtually anywhere :D

comment:6 Changed 2 years ago by Tomasz Jakut

Resolution: fixed
Status: reviewclosed

LGTM. Fixed with git:05987f5.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy