Opened 2 years ago

Closed 2 years ago

#16746 closed Bug (invalid)

config.forceSimpleAmpersand does not work

Reported by: Wiktor Walc Owned by:
Priority: Nice to have (we want to work on it) Milestone:
Component: General Version: 4.0
Keywords: Support Cc: william@…, julian.ivancsuk@…

Description

Steps to reproduce

  1. Start CKEditor with the following config
    		CKEDITOR.replace( 'editor1', {
    			forceSimpleAmpersand: true
    		} );
    
  2. Type & in wysiwyg mode
  3. Switch to source mode

Expected result

&

Actual result

&

Other details (browser, OS, CKEditor version, installed plugins)

Reproduced on Chrome. Reproducible since 4.3.2 at least, did not try earlier versions.

Change History (9)

comment:1 Changed 2 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 2 years ago by Wiktor Walc

Keywords: Support added

comment:3 Changed 2 years ago by William Gordon

Cc: william@… added

comment:4 Changed 2 years ago by Jakub Ś

Version: 4.0

Problem can be reproduced at least from CKEditor 4.0.

comment:5 Changed 2 years ago by julian_ivancsuk

Problem can be reproduced in version 4.6.1

comment:6 Changed 2 years ago by julian_ivancsuk

Cc: julian.ivancsuk@… added

comment:7 Changed 2 years ago by Marek Lewandowski

Priority: NormalNice to have (we want to work on it)

comment:8 Changed 2 years ago by Tade0

Apparently this option works only for element attribute values.

We could extend it so that it also gives the behaviour desired here.

comment:9 Changed 2 years ago by Wiktor Walc

Resolution: invalid
Status: confirmedclosed

Actually I just checked the history of this configuration option and it looks like it in fact works this way by design. Just the description of the configuration option is misleading. See how it was described long time ago: https://docs.cksource.com/FCKeditor_2.x/Developers_Guide/Configuration/Configuration_Options/ForceSimpleAmpersand

I'm closing this issue as invalid since this option must stay unchanged. Otherwise backwards compatibility will be a problem.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy