Opened 2 years ago

Closed 2 years ago

#16798 closed Bug (invalid)

Unable to save cursor position on page reload or after saving data

Reported by: Mubin Owned by:
Priority: Normal Milestone:
Component: Core : Focus Version: 4.5.6
Keywords: Cc: sakshi.solanki@…, mubin.shaikh@…

Description

Steps to reproduce

1.I have one data in ckeditor or i can add my own data in to ckeditor then the cursor blinks when i type into ckeditor near to new text added till i add new text.

  1. After this i click on save as draft button (see attached image), then the ckeditor not able to focus on the place where i was editing or adding new text and cursor position get loss.
  2. After saving data (means after saving data page get reload) cursor should blink on the position where i was typing or adding text before saving data.

Expected result

After saving data cursor should blink on near to same text where i was editing before saving data.

Actual result

After saving data cursor position loss.

Other details (browser, OS, CKEditor version, installed plugins)

plugin version : 4.5.6. browser : chrome

Attachments (3)

cursrorBeforeSaving.png (39.7 KB) - added by Mubin 2 years ago.
This is file before saving data and before addin text.
cursorAfterSomeText.png (35.2 KB) - added by Mubin 2 years ago.
This is image, which describe i have added new text in existing data but before saving data.
AfterSavingText.png (48.0 KB) - added by Mubin 2 years ago.
This image describes that i have added text and click on save as draft button.

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by Mubin

Attachment: cursrorBeforeSaving.png added

This is file before saving data and before addin text.

Changed 2 years ago by Mubin

Attachment: cursorAfterSomeText.png added

This is image, which describe i have added new text in existing data but before saving data.

Changed 2 years ago by Mubin

Attachment: AfterSavingText.png added

This image describes that i have added text and click on save as draft button.

comment:1 Changed 2 years ago by Mubin

i have used below code for selecting cursor position. But this is working fine till saving data or page reload. Means i can navigate to browser or i can check after few minutes into ckeditor then i am able to see cursor blinking but this will not work after saving data or page reload. Please check it.

var range=; sectionStoryEditor.on( 'blur', function() { range = sectionStoryEditor.getSelection().getRanges()[ 0 ]

sectionStoryEditor.focus();

range.select(); });

comment:2 Changed 2 years ago by Jakub Ś

Keywords: focus cursor page reload removed
Resolution: invalid
Status: newclosed

This is not a bug as we simply don't support such functionality.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy