Opened 12 years ago

Closed 6 years ago

#1680 closed Bug (fixed)

Editor unusable when wrapped in an invisible div having a fixed width

Reported by: wimpie3 Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: Cc:

Description

Internet Explorer pops up an error window with the following message: Could not complete the operation due to error 800a025e

The error is due to the line mText1.Value = "". When I replace this line with mText1.Value = "blahblah" it works..

This is the code I've used. Worked fine in previous versions of FCKeditor.

<div style="WIDTH:715;display:none;">

<script type="text/javascript" src="/CFIDE/scripts/FCKeditor/fckeditor.js"> </script> <script type="text/javascript">

var mText1 = new FCKeditor('mText1') ; mText1.BasePath = "/CFIDE/scripts/FCKeditor/" ; mText1.Value = ""; mText1.Create(); </script>

</div>

Change History (6)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: bug div wrap removed
Milestone: FCKeditor 2.6
Priority: HighNormal

comment:2 Changed 12 years ago by Tom

I'm having the same problem. I've tried the latest nightly build, and I get this error consistently in IE7:

Line: 33 Char: 12465 Error: Could not complete the operation due to error 800a025e. Code: 0 URL: https://.../fckeditor.html?InstanceName=CommentText&Toolbar=Basic

Like the original poster, I'm trying to use FCKEditor in an invisible div. Seems like a common enough thing to do.

comment:3 Changed 12 years ago by Tom

Also note that if I revert back to version 2.4.3, I don't have this issue. Anything newer than 2.4.3, and it happens.

Thanks, Tom

comment:4 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added

Confirmed in IE and also in FF2 using version 2.5.1

comment:5 Changed 11 years ago by Joe Wieloch

I found a problem with the _FCK_PaddingNodeListener see my post here:

http://www.fckeditor.net/forums/viewtopic.php?f=6&t=8700&st=0&sk=t&sd=a&start=10

comment:6 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

Such error doesn’t occur in latest CKEditor 4.1

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy