Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#16819 closed Bug (wontfix)

Media Embed plugin does not work on https

Reported by: tisdall Owned by:
Priority: Normal Milestone:
Component: General Version: 4.7.1
Keywords: Cc:

Description

Steps to reproduce

  1. add "embed" to an editor instance on an https page
  2. try to embed a youtube link and you'll get a message saying "Failed to fetch content for the given url"

Problem

The problem is the default providerUrl is '//ckeditor.iframe.ly/api/oembed?url={url}&callback={callback}' which means it uses the protocol of the page. iframe.ly has a certificate, but it doesn't cover "ckeditor.iframe.ly" so the request fails. So, the solution is for iframe.ly to add that subdomain to its certificate (or wildcard) or for the plugin to explicitly use "http".

Workaround

The plugin accepts a embed_provider configuration that would allow setting it to "http://ckeditor.iframe.ly/api/oembed?url={url}&callback={callback}" until a permanent solution is found.

Change History (2)

comment:1 Changed 2 years ago by tisdall

Resolution: wontfix
Status: newclosed

#14297 - I just saw this... sorry.

comment:2 Changed 2 years ago by tisdall

actually... I'm wondering if it should still have the protocol explicitly set since https will never work.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy