Opened 2 years ago

Closed 2 years ago

#16870 closed Bug (invalid)

[IE] Backspace skips empty paragraphs

Reported by: Tade0 Owned by:
Priority: Normal Milestone:
Component: General Version: 4.7.0
Keywords: Cc:

Description (last modified by Tade0)

Steps to reproduce

  1. Open http://tests.ckeditor.dev:1030/tests/plugins/widget/manual/block
  2. Put the caret at the start of the paragraph under the image widget(The spelling "Lenna"...).
  3. Hit backspace.
  4. Hit the enter key a few times.
  5. Hit backspace.

Expected result

One empty paragraph is removed.

Actual result

Widget is selected.

Other details (browser, OS, CKEditor version, installed plugins)

The error occurs because only in IE this method: http://docs.ckeditor.com/#!/api/CKEDITOR.dom.range-method-getPreviousEditableNode ignores empty paragraphs.

Change History (3)

comment:1 Changed 2 years ago by Tade0

Status: newconfirmed

comment:2 Changed 2 years ago by Tade0

Description: modified (diff)

comment:3 Changed 2 years ago by Tade0

Resolution: invalid
Status: confirmedclosed

Apparently this is what happens if the enter key plugin is not present.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy