Opened 3 years ago

Closed 2 years ago

#16874 closed Bug (fixed)

Error in console (Cannot read property 'isContextFor' of null)

Reported by: Sergey Owned by: beata_delura
Priority: Normal Milestone:
Component: General Version: 4.4.6
Keywords: Webkit Blink Cc:

Description

Steps to reproduce

  1. Go to http://ckeditor.com/
  2. Select Article Editor tab
  3. Remove all data
  4. Input some string (e.g. "Hello")
  5. Select part of the string (e.g. "llo")
  6. Click below the text (blinking cursor will disappear)
  7. Click "Enter"

Expected result

No error

Actual result

Error in console: Uncaught TypeError: Cannot read property 'isContextFor' of null

Other details (browser, OS, CKEditor version, installed plugins)

Browser: Google Chrome, v.56.0.2924.87, locale: ru CKEditor version: 4.6.2 (Tested on the CKEditor's site) Default plugins

Attachments (5)

BUG.png (35.0 KB) - added by Sergey 3 years ago.
Bug2.png (8.2 KB) - added by Sergey 3 years ago.
Bug3.png (8.5 KB) - added by Sergey 3 years ago.
Bug4.png (10.9 KB) - added by Sergey 3 years ago.
Bug5.png (35.8 KB) - added by Sergey 3 years ago.

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by Sergey

Attachment: BUG.png added

Changed 3 years ago by Sergey

Attachment: Bug2.png added

Changed 3 years ago by Sergey

Attachment: Bug3.png added

Changed 3 years ago by Sergey

Attachment: Bug4.png added

Changed 3 years ago by Sergey

Attachment: Bug5.png added

comment:1 Changed 3 years ago by Jakub Ś

Keywords: Webkit Blink added; Bug removed
Status: newconfirmed
Version: 4.6.24.4.6

Problem can be reproduced in Blink and Webkit browsers from CKEditor 4.4.6.

comment:2 Changed 3 years ago by beata_delura

Owner: set to beata_delura
Status: confirmedassigned

comment:3 Changed 3 years ago by kkrzton

Status: assignedpending

The cause of this issue is related to some native Blink behaviour. I reported the issue here: https://bugs.chromium.org/p/chromium/issues/detail?id=719430.

comment:4 Changed 3 years ago by kkrzton

Status: pendingconfirmed

The reported bug was closed as WontFix (https://bugs.chromium.org/p/chromium/issues/detail?id=719430#c3) so if we are planning to fix the issue some workaround of the problem will be needed.

comment:5 Changed 3 years ago by beata_delura

Status: confirmedassigned

comment:6 Changed 3 years ago by beata_delura

Status: assignedreview

comment:7 Changed 2 years ago by beata_delura

Status: reviewassigned

comment:8 Changed 2 years ago by beata_delura

Status: assignedreview

comment:9 Changed 2 years ago by kkrzton

Resolution: fixed
Status: reviewclosed

Fixed with #478.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy