Opened 7 months ago

Closed 6 months ago

#16890 closed Bug (expired)

Problems when copy from the word

Reported by: Timur Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Disable removing empty spans (this feature is important because spans retain the formatting)
  2. Copy table with empty cells
  3. Try to set cursor in the empty cell

Expected result

Need give an opportunity to put the cursor in the cell.

Actual result

Can't set cursor in the cell

Other details (browser, OS, CKEditor version, installed plugins)

Change History (2)

comment:1 Changed 7 months ago by Jakub Ś

Status: newpending
Version: 4.7.0 (GitHub - major)

Tables don't need spans to focus cells. When empty table is displayed in WYSIWYG mode, cells are filled with <br> tags in Source mode it is filled with &nbsp;. This is how it works by default in every browser.

From what I can see tables from word are pasted with empty paragraph inside by default so there is no problem with focusing items.


  1. How exactly have you disabled removing spans?
  2. Have you made any CKEditor core code customizations which might have changed the default behaviour?
  3. What is your editor pre-set? Could you attach your build-config.js and config.js files?

comment:2 Changed 6 months ago by Jakub Ś

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy