Opened 12 years ago

Closed 8 years ago

#1698 closed Bug (worksforme)

Phantom scrollbar problem experienced when switching between normal and expanded editor views

Reported by: Lucille Leitz Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.3
Keywords: Firefox Mac Cc: mgmt@…

Description

A new client sent me the attached .PNG examples of an ongoing "phantom scrollbar" problem experienced when switching between a "normal" and "expanded" view in the FCKEditor (version 2.4.3) with Java integration (version 2.3).

I'm also attaching copies of the editor/css/fck_editorarea.css and editor/skins/default/fck_editor.css files.

Mac OSX 10.4.10 (Tiger) is the OS and Firefox is the browser. The problem is reportedly occurring only on the Mac.

I don't have a Mac, so must analyze the problem in the doc and on the Wiki. So far, I haven't seen a clue to a possible answer from either doc or Wiki.

Advice or suggestions?

Attachments (5)

expanded wysiwig_view.png (184.9 KB) - added by Lucille Leitz 12 years ago.
Expanded editor view
regular_wysiwig_view.png (163.8 KB) - added by Lucille Leitz 12 years ago.
Regular editor view
fck_editorarea.css (2.0 KB) - added by Lucille Leitz 12 years ago.
fck_editorarea.css
fck_editor.css (7.7 KB) - added by Lucille Leitz 12 years ago.
fck_editor.css
TC_1698.html (1.9 KB) - added by Frederico Caldeira Knabben 12 years ago.
TC

Download all attachments as: .zip

Change History (18)

Changed 12 years ago by Lucille Leitz

Attachment: expanded wysiwig_view.png added

Expanded editor view

Changed 12 years ago by Lucille Leitz

Attachment: regular_wysiwig_view.png added

Regular editor view

Changed 12 years ago by Lucille Leitz

Attachment: fck_editorarea.css added

fck_editorarea.css

Changed 12 years ago by Lucille Leitz

Attachment: fck_editor.css added

fck_editor.css

comment:1 Changed 12 years ago by Michael Osipov

Milestone: FCKeditor.Java 2.4

your phantom bars are from your select fields. These problems are purely client-side problems with the FCKeditor. Not a Java-related issue since Java is server-side.

comment:2 Changed 12 years ago by Lucille Leitz

Can you clarify what you mean by "from your select fields"? Do you mean:

  1. the select-field text values

or

  1. the select-field options markup

or

  1. the FCKEditor JavaScript function(s) that execute when the user selects "Maximize the editor size" from the editor toolbar

or

  1. none of the above, but something else altogether?

To give further background:

This client's developers run FCKEditor integrated into a .JSP content admin application, which runs on an internal Apache server. They always have to go to the admin application's home, then navigate to an articles-edit URL to access the FCKEditor.

The select-field text values displayed in the example edit page views are part of a record retrieved by a Java class from an Oracle 9i database table along with their record id numbers (not displayed but visible in ViewSource). The marked-up text that appears inside the FCKEditor is part of the same retrieved record. Oracle stores it as a CLOB (character large object).

Below is the markup for the select field with the "phantom scrollbar" problem.

<br> Body Include Path: <input type="text" name="bodyIncludePath" value=""><br> Categories: <select name="relatedCategories" multiple>

<option value="4">Accessories</option>

<option value="61">Articles</option>

<option value="3">Flashes</option>

<option value="82">Interview</option>

<option value="5">Lenses</option>

<option value="81">Photo Contest</option>

<option SELECTED value="1">Pro Corner</option>

<option SELECTED value="42">Product</option>

<option value="21">Softwares</option>

<option value="41">Techniques</option>

<option SELECTED value="2">Technology</option>

</select><br>

comment:3 in reply to:  1 ; Changed 12 years ago by Lucille Leitz

Can you clarify what you mean by "from your select fields"? Do you mean:

  1. the select-field text values or b. the select-field options markup or c. the FCKEditor JavaScript function(s) that execute when the user selects "Maximize the editor size" from the editor toolbar or d. none of the above, but something else altogether?

To give further background:

This client's developers run FCKEditor integrated into a .JSP content admin application, which runs on an internal Apache server. They always have to go to the admin application's home, then navigate to an articles-edit URL to access the FCKEditor.

The select-field text values displayed in the example edit page views are part of a record retrieved by a Java class from an Oracle 9i database table along with their record id numbers (not displayed but visible in ViewSource). The marked-up text that appears inside the FCKEditor is part of the same retrieved record. Oracle stores it as a CLOB (character large object).

Below is the markup for the select field with the "phantom scrollbar" problem.

<br> Body Include Path: <input type="text" name="bodyIncludePath" value=""><br> Categories: <select name="relatedCategories" multiple>

<option value="4">Accessories</option>

<option value="61">Articles</option>

<option value="3">Flashes</option>

<option value="82">Interview</option>

<option value="5">Lenses</option>

<option value="81">Photo Contest</option>

<option SELECTED value="1">Pro Corner</option>

<option SELECTED value="42">Product</option>

<option value="21">Softwares</option>

<option value="41">Techniques</option>

<option SELECTED value="2">Technology</option>

</select><br>

Replying to mosipov:

your phantom bars are from your select fields. These problems are purely client-side problems with the FCKeditor. Not a Java-related issue since Java is server-side.

comment:4 in reply to:  3 ; Changed 12 years ago by Michael Osipov

Replying to lobl:

Can you clarify what you mean by "from your select fields"? Do you mean:

By select fields I simple mean those fields you put below the FCKeditor, e.g. the one from accessories thru technology and the second select field with the camera models. It seems like the fields are not hidden correctly behind the editor.

I will explain why has nothing to do with the Java Connector.

You probably create the editor with the Tag, basically what is does is creating some input fields calling some JS files, from this point it is all client-side. The full screen expansion is client-side with JS. The browser gets simple HTML/JS from the servlet container.

You'd probably have the same problem with another connector.

Did you already try the latest version (2.5.1)? The problem could be gone.

comment:5 in reply to:  4 Changed 12 years ago by Lucille Leitz

I do not disagree that the problem is on the client side. I just needed more clarification as to what you meant, and I provided runtime information to give you background.

I didn't need to know that the fields aren't hidden correctly behind the editor. That was the client's complaint to begin with, and the examples make it obvious. However, this ONLY happens on the Mac/Firefox combination that I provided when I opened the ticket. There is no problem at all on Windows/IE and Windows/Firefox combinations.

Although I agree that the problem may have been fixed in 2.5/2.5.1, this client is not willing to upgrade. To give you an example, their runtime Java version is 1.4 with J2EE 1.3 (no longer available from Sun, much less supported), the release of Oracle that the Java/JSP application interfaces with is 9i, and they have yet to move their Microsoft applications to .NET. They're not willing to pay for the upgrade time, so I'm stuck with the version I inherited from the previous developer.

Replying to mosipov:

Replying to lobl:

Can you clarify what you mean by "from your select fields"? Do you mean:

By select fields I simple mean those fields you put below the FCKeditor, e.g. the one from accessories thru technology and the second select field with the camera models. It seems like the fields are not hidden correctly behind the editor.

I will explain why has nothing to do with the Java Connector.

You probably create the editor with the Tag, basically what is does is creating some input fields calling some JS files, from this point it is all client-side. The full screen expansion is client-side with JS. The browser gets simple HTML/JS from the servlet container.

You'd probably have the same problem with another connector.

Did you already try the latest version (2.5.1)? The problem could be gone.

comment:6 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: phantom scrollbars removed

@mosipov : there is no need for extensive explanations and discussions just to tell that the ticket was wrongly targeted. The reporter could get confused, as he got.

Many times, people use the classification fields as a "survey" and don't realize that they are intended for the developers team use. In this case, it is enough to correct the Milestone or Component fields to the proper values as this ticket is clearly related to a browser bug.

comment:7 in reply to:  6 ; Changed 12 years ago by Lucille Leitz

I cannot find instructions in the Wiki for changing the Component or Milestone field. On this page, I can only reply and comment. Can you point me in the right direction?

Replying to fredck:

@mosipov : there is no need for extensive explanations and discussions just to tell that the ticket was wrongly targeted. The reporter could get confused, as he got.

Many times, people use the classification fields as a "survey" and don't realize that they are intended for the developers team use. In this case, it is enough to correct the Milestone or Component fields to the proper values as this ticket is clearly related to a browser bug.

comment:8 in reply to:  7 Changed 12 years ago by Michael Osipov

Replying to lobl:

I cannot find instructions in the Wiki for changing the Component or Milestone field. On this page, I can only reply and comment. Can you point me in the right direction?

Lobl,

you can't obviously. Only a dev can do that. Like fredck or me.

comment:9 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added

In order to understand where is the problem you should try to generate a simple testcase that does fail for the client and attach it here so it can be reproduced.

The server code isn't interesting as it can't be the problem, just use one of the javascript samples.

I've tested with sample 3 but it works fine.

Changed 12 years ago by Frederico Caldeira Knabben

Attachment: TC_1698.html added

TC

comment:10 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Firefox Mac added; Pending removed

The reporter did a great job and the provided information was enough to understand that the bug exists and that it is caused by a Firefox bug.

I've attached a TC for it.

comment:11 Changed 12 years ago by Frederico Caldeira Knabben

This is definitely a browser bug. It needs a ticket at Mozilla's Bugzilla.

comment:12 Changed 12 years ago by Alfonso Martínez de Lizarrondo

I see why I wasn't able to create a testcase myself. I was using Firefox 3 beta2, and this bug doesn't happen in this version, so it's not worth filing a bug in Mozilla because it will be marked as dup of the fixed bug.

comment:13 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy