#16989 closed Bug (invalid)

Text loses some formatting when pasting in text from Google Docs

Reported by: Diana Aspillera Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Open a Google doc with bold, italic, bulleted/numbered formatting (Chrome/Safari/Firefox)
  2. Paste into instance of CKEditor (using special paste from tools)
  3. Save

Expected result

Formatting to be preserved

Actual result

Only formatting preserved were links. Bold, italic, bullets, and numbers were lost in Firefox Bullets and numbers were lost, but bold and italic were maintained in Chrome/Safari

Other details (browser, OS, CKEditor version, installed plugins)

OS - Mac OSX El Capitan CKEditor version - 4.6

Attachments (1)

build-config.js (3.3 KB) - added by Diana Aspillera 20 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 20 months ago by Jakub Ś

Status: newpending
Version: 4.6.0

Could you paste your build-config.js or show me your ACF settings? I have just checked Google Docs and Firefox in CKEditor full package and all styles were preserved - bolds, italic bullets and numbers.

Changed 20 months ago by Diana Aspillera

Attachment: build-config.js added

comment:2 Changed 20 months ago by Diana Aspillera

Thanks - here's the build-config.js

comment:3 Changed 19 months ago by Jakub Ś

Hi, I'm sorry for late reply.

I have checked your build-config but there is nothing special there. It looks standard for full package. You have basicstyles and list, liststyle plugins so pasting should work as expected.

Could you tell me if you are using any custom plugins or perhaps you have some custom editor configuration which might be removing certain tags? Perhaps you have some filter in your application which doesn't honour e.g. strong tags?

comment:4 Changed 19 months ago by Diana Aspillera

We try to keep the resulting markup sane, so the issue is probably there. Thanks for your time!

comment:5 Changed 19 months ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Thank you for letting us know. I will close the ticket.

If you find CKEditor to be the problem after all, please leave a comment and I will reopen the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy