Opened 12 years ago

Closed 11 years ago

#1701 closed Bug (wontfix)

<span class="Apple-style-span"> for Bold with "Cmde" "B"

Reported by: laurent royer Owned by:
Priority: Normal Milestone: FCKeditor 2.6.1
Component: General Version: FCKeditor 2.5.1
Keywords: Confirmed Safari Mac CantFix Cc:

Description

Os : Mac OS X.4 Browser : Safari 3.0.4

Following the resolved ticket #55, the case creating bold with short key "Cmde B" still generate : <span class="Apple-style-span" style="font-weight: bold;">. The other case are resolved.

Attachments (1)

1701.html (1.5 KB) - added by Martin Kou 11 years ago.
Test case to show Meta-B and Meta-I cannot be received by JavaScript in Safari for Mac.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Bold removed

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Safari Mac added
Milestone: Safari CompatibilityFCKeditor 2.6.1

Confirmed with Safari 3.1.

The problem here is that our keystrokes are being mapped to the CTRL key, not the META key, as usual to Safari Mac. So, the default browser behavior is being executed for META+B, while our controlled bold style is being applied with CTRL+B.

On Safari Mac, we must set all CTRL keystroke settings to the META key, instead of the Mac CTRL, still using CTRL on Firefox, as this is instead the key used by that browser by default (and the reason why we use CTRL today).

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Component: Core : StylesGeneral

comment:4 Changed 11 years ago by Martin Kou

Keywords: CantFix added

I just did some experiments with Safari and found that the Meta keys are actually correctly received by FCKeditor (e.g. Meta-Z, Meta-Y and Meta-V works as expected), with the exception of Meta-B and Meta-I. The problem here is that the editor mode in Safari for Mac does not allow JavaScript to receive Meta-B and Meta-I events.

I think there's nothing FCKeditor can do to fix this at the moment, as the bug should be fixed in WebKit's side instead.

Changed 11 years ago by Martin Kou

Attachment: 1701.html added

Test case to show Meta-B and Meta-I cannot be received by JavaScript in Safari for Mac.

comment:5 Changed 11 years ago by Martin Kou

Resolution: wontfix
Status: newclosed

I've filed a bug report to the WebKit developers at https://bugs.webkit.org/show_bug.cgi?id=18693.

Closing ticket as wontfix since it cannot be fixed on our side.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy