Opened 3 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#17033 closed Bug (duplicate)

extractContents returns incorrect result when multiple nodes are selected.

Reported by: Jakub Ś Owned by:
Priority: Nice to have (we want to work on it) Milestone:
Component: General Version: 4.5.0
Keywords: Chrome Support Cc:

Description (last modified by Jakub Ś)

Steps to reproduce

  1. Put attached sample into ckeditor/samples folder and open it
  2. Apply same styles and selections as in attached video:
    • This is some [sample text.] - apply yellow marker
    • This is [some sample text.] - apply underline
    • [This is some sample text.] - press Print Extract Contents button

Expected result

This is <u>some <span class="marker"><strong>sample text</strong>.</span></u>

Actual result

This is <u><span class="marker">.<strong>sample text</strong></span>some </u>

The text content in Document Fragment is "This is .sample textsome "

Other details (browser, OS, CKEditor version, installed plugins)

Problem can only be reproduced in all browsers starting from CKEditor 4.5.0.

Attachments (2)

2017-05-15_2016.swf (799.5 KB) - added by Jakub Ś 3 months ago.
api2.html (7.4 KB) - added by Jakub Ś 3 months ago.

Download all attachments as: .zip

Change History (8)

Changed 3 months ago by Jakub Ś

Attachment: 2017-05-15_2016.swf added

Changed 3 months ago by Jakub Ś

Attachment: api2.html added

comment:1 Changed 3 months ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 3 months ago by Jakub Ś

Most likely related to #17030

comment:3 Changed 3 months ago by Jakub Ś

Keywords: Support added

comment:4 Changed 3 months ago by Marek Lewandowski

Priority: NormalNice to have (we want to work on it)

comment:5 Changed 6 weeks ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

It has turned out this is a duplicate of #14256.

comment:6 Changed 6 weeks ago by Jakub Ś

Description: modified (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy