Opened 10 years ago

Closed 10 years ago

Last modified 4 years ago

#1707 closed Bug (fixed)

IE : Loop while formatting Word pasted data

Reported by: Luis Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6
Component: Plugin : Paste from Word Version: FCKeditor 2.5
Keywords: IE Review+ Cc:

Description

Hi,

I´m getting this bug since release 2.5, aparentely due to a javascript loop on text format commands. The page freezes and returns a message asking me to stop the script that is taking too long to run. That also happens on the demo page for this site when you put a long text (it doesn´t need to be that long), containing paragraphs with different text formats, select it all and try to do any formatting with it, such as right aligning.

I´m using Internet Explorer 6.0 and Windows XP.

Hope you find a solution on that enableing me to upgrade FCKEditor, solving most of the problems I have on the previous versions.

Thanks,

Luís

Attachments (3)

bug_fckeditor.doc (179.5 KB) - added by Luis 10 years ago.
Sample Data and Screenshot
1707.patch (1.0 KB) - added by Martin Kou 10 years ago.
Proposed patch for fixing #1707.
1707_2.patch (887 bytes) - added by Martin Kou 10 years ago.
Simplified patch for fixing #1707.

Download all attachments as: .zip

Change History (18)

Changed 10 years ago by Luis

Attachment: bug_fckeditor.doc added

Sample Data and Screenshot

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Confirmed IE added
Milestone: FCKeditor 2.6
Priority: NormalHigh
Summary: PAGE FREEZES WHILE FORMATTING (JAVASCRIPT ERROR)IE : Loop while formatting Word pasted data
Version: FCKeditor 2.5

Confirmed with IE. No problem with other browsers.

I've reduced the TC for it:

  1. Load the following HTML:
<p><b>SAMPLE DATA<o:p></o:p></b></p>
  1. Align the "SAMPLE DATA" paragraph to right.

The browser will loop.

It works well by removing the <b> or the MS Office <o:p> tags.

comment:2 Changed 10 years ago by Luis

Remember that it also happens when you write text with lots of paragraphs, containing different formats, straight on fckeditor. It´s not necessarily a pasted data from word. Thanks again, Luís

comment:3 in reply to:  2 Changed 10 years ago by Frederico Caldeira Knabben

Replying to oliveira_lcs:

Remember that it also happens when you write text with lots of paragraphs, containing different formats, straight on fckeditor. It´s not necessarily a pasted data from word.

For that case Luis, we need the precise steps to reproduce it. We can only work on facts, not theories.

Thanks for the update.

comment:4 Changed 10 years ago by Luis

You´re right. That happened to me on 2.5. I´ve tried to reproduce it on the actual demo page without success, so maybe it´s fixed for 2.5.1. Thank you and I hope you find a solution for the word pasted data soon.

comment:5 Changed 10 years ago by Carlos Hespanhol

I found that it get in a loop at "while ( ( block = iterator.GetNextParagraph() ) )" in fckjustifycommands.js.

iterator.GetNextParagraph() keeps returning <B></B> while variable currentnode in function GetNextParagraph() have <B><?xml:namespace prefix = o /><o:p></o:p></B>

I guess it is a matter of deleting the empty tag <B></B> at the end of the function, I just dont know how to do it.

comment:6 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 10 years ago by Martin Kou

Attachment: 1707.patch added

Proposed patch for fixing #1707.

comment:7 Changed 10 years ago by Martin Kou

Keywords: Review? added; Confirmed IE removed

Changed 10 years ago by Martin Kou

Attachment: 1707_2.patch added

Simplified patch for fixing #1707.

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Please include the changelog entry when committing.

comment:9 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [1409].

Click here for more info about our SVN system.

comment:10 Changed 10 years ago by Luis

Resolution: fixed
Status: closedreopened

I just tested with the changed file and it still freezes while formatting. Guess it needs to be reviwed. Thank you once again, Luís

comment:11 Changed 10 years ago by Martin Kou

Hi Luís,

Did you apply the patch to our released source package or to the SVN source tree? I'm asking this because applying the patch to the release source package has no effect - the source code in the downloadable package is there for viewing purpose only, it is not loaded by the browser. The patch is only effective if you apply it to the SVN source tree.

comment:12 Changed 10 years ago by Frederico Caldeira Knabben

You may also try our nightly build.

comment:13 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: IE added
Resolution: fixed
Status: reopenedclosed

I've tested it with both the reported TC as well as with the reduced TC described in comment:1. It works for me on both cases.

Feel free to reopen it if it is still a problem. In that case, please provide the precise instructions to reproduce it.

comment:14 Changed 10 years ago by Luis

It did work for the nightly build. Thank you!!!

comment:15 Changed 4 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy