Opened 12 years ago

Closed 8 years ago

#1714 closed Bug (invalid)

cursor jumps from beginning of text area to the end

Reported by: Susie Sahim Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Cc: armorrison@…

Description

Descriptive summary: When you have the editor set to load content starting with <br> tags and later followed by text wrapped in a <div> it prevents the user from clicking on the first line of the text field. when clicked, it just jumps to the bottom of the text area.

Browser name and OS: Tested on two separate computers with Firefox 2.0.0.11 on Windows XP Pro Service Pack 2

Steps to reproduce: In Firefox, have the FCK editor's $FCKeditor->Value set with something like as follows: <br /> <div><p>Hello World</p></div> View the web page containing the text editor. After the text editor loads and the user clicks on the first line of the text area (the line with the <br/> tag), the cursor appears at the top for just a split second, then jumps down to the bottom of the text area. When trying to click on the first line again, it just keeps jumping back to the bottom. If you remove the <div></div> tags surrounding the text on the lower portion of the text field in $FCKeditor->Value, the cursor no longer appears to jump. So this seems to have something to do with the <div> and the text area beginning with <br />.

I have been a long time user of FCK editor and recently upgraded to the latest version. This bug just started appearing with the latest version.

Attachments (2)

default text fck editor.txt (260 bytes) - added by Susie Sahim 12 years ago.
Sample text to set for $FCKeditor->Value
TC_1714.html (791 bytes) - added by Wojciech Olchawa 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by Susie Sahim

Attachment: default text fck editor.txt added

Sample text to set for $FCKeditor->Value

Changed 12 years ago by Wojciech Olchawa

Attachment: TC_1714.html added

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added
Version: FCKeditor 2.5.1

Hi! I was unable to reproduce this bug. I followed your instruction and applied your sample code to the page and everything seems to work fine. I've attached a sample file of the page. Try to reproduce the bug with this page.

Thanks!

comment:2 Changed 11 years ago by Wojciech Olchawa

Resolution: worksforme
Status: newclosed

Ticket expired.

comment:3 Changed 11 years ago by Aaron

Cc: armorrison@… added
Resolution: worksforme
Status: closedreopened

I am hitting this bug as well. Firefox only. I am on version 2.0.0.15. My fckeditor version is 2.6.2. The text given by BogusRed is the resulting source code as translated by fckeditor.

w.olchawa, try using this instead in your test:

oFCKeditor.Value = '<br><div>Hello World</div>'

then the behaviour he describes occurs.

The source in the editor will look like this: <p>&nbsp;</p> <div>Hello World</div>

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Pending removed

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe removed

comment:6 Changed 8 years ago by Krzysztof Studnik

Resolution: invalid
Status: reopenedclosed

in CKE r7141 Entermode_P - </BR> tag on the beggining is removed, as expected. Closing ticket cannot reproduce issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy