Opened 10 years ago

Closed 6 years ago

#1716 closed Bug (worksforme)

FCK Selection IE + Flashing cut and copy toolbar icons + optimisation

Reported by: Scott McNaught Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version:
Keywords: IE Cc:

Description

This is just a small tweak.

To replicate: hold down the enter key in the editor. When the cursor gets to the point when it starts to scroll, the cut and copy toolbar items flash on and off.

This is a result of the selection hack of the zero-width space in IE.

I beleive this can be fixed by temporarilly detaching onselectionchange events when running this code.

Detaching the onselectionchange event will also provide a possible optimisation and make pressing enter execute a little bit faster.

Change History (4)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.7

Nice idea Scott. It should be easy to implement, by append an API property to lock the toolbar, forcing the toolbarset to not dispatch change events to the items.

comment:2 Changed 9 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:3 Changed 9 years ago by Wojciech Olchawa

Keywords: IE added

comment:4 Changed 6 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

I cannot reproduce such behaviour in v3.6.x
FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy