Opened 12 years ago

Closed 7 years ago

#1772 closed Bug (wontfix)

cmd-[back arrow] on FF Mac navigates browser instead of moving cursor in editor

Reported by: Sarah Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Firefox Mac Cc:

Description

Browser: FF 2 OS: mac (os x 10.4)

Normally, while editing in a standard text area, I can press the CMD-back arrow (also known as "open-apple, left-arrow") to move my cursor to the beginning of a line.

In the FCK editor (see latest build: http://www.fckeditor.net/nightly/fckeditor/_samples/default.html) the "open-apple, left-arrow" will navigate you one page back in history in FireFox. NOTE, this only occurs if you actually have history. If there is no history, it seems to do the correct thing and move your cursor to the beginning of the line.

Navigating back in your history is actually the correct browser behavior, EXCEPT when you are doing some text editing.

Seems to work correctly in your latest build on Safari though!

To Reproduce:

  1. View your nightly build in a browser window
  2. type some stuff
  3. type CMD-[back arrow]
  4. If your browser window had history, you will navigate back one page. If not, you will move to the beginning of the line

Change History (5)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Confirmed Firefox Mac added
Version: SVN

Confirmed with FF2 Mac. Ok with Safari 3 Mac and FF2 Windows.

It's a browser bug. Needs ticket at Mozilla's Bugzilla.

comment:2 Changed 12 years ago by Sarah

okay, thanks for looking into this! I'll file it with Mozilla.

comment:3 Changed 11 years ago by Turadg Aleahmad

I looked in Mozilla's Bugzilla and couldn't find this issue there. sj_waterson, if you filed/found it there, can you comment on this ticket with a link to it?

Incidentally, there's a blog thread discussing the bug.

comment:4 Changed 11 years ago by Turadg Aleahmad

It's bug #341886 in Mozilla's Bugzilla. It only has a couple votes yet.

comment:5 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy