Opened 11 years ago

Closed 8 years ago

#1784 closed Bug (worksforme)

text formatting (bold, italic, underline) gets confused

Reported by: Brian Woodruff Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Firefox Cc:

Description

I was doing some simple tests on the demo site and found the editor loses track of formatting changes in a way that effectively disable the bold, italic and underline features.

This problem occurs in version 2.5.1. Version 2.0 RC2 did NOT have this problem. I have not tried interim versions.

To duplicate the error, type this text into the editor:

This is the text.

Doubleclick the word "text", selecting the word. Click the bold, italic and underline buttons to add this formatting to the word.

Doubleclick the word "the " and type "some ", replacing the word. The new word, "some " will have the same bold, italic, underline formatting of the word "text".

Bug 1: doubleclick the word "text". You will not be able to undo the formatting on this word.

Now select both words - all of the text with bold italic underline formatting. You will be able to undo this formatting for the second word, "text", but not the word in front of it, "some ".

Bug 2: even after you are done working with this selection, if you try to select the word "some " and change any of the formatting, you will not be able to.

In essence, it is possible for the user to create formatting which can not be undone.

Change History (3)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed Firefox added
Version: FCKeditor 2.5.1

comment:2 Changed 11 years ago by Julia

I'm interested too. (If this bug really corresponds to my problem, I will give details too as soon as possible)!

comment:3 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy