Opened 10 years ago

Closed 10 years ago

#1806 closed Bug (fixed)

Wrong selection when selecting a Header format at new line in the end of the document

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Review+ Cc: Jamal

Description

This is a IE only issue.

Steps to Reproduce

  1. Clear the editor contents.
  2. Type some text.
  3. Hit ENTER.
  4. Select any Header style in the Format combo.

With IE, the cursor will start blinking at the end of the previous paragraph. Moving down with the arrow key shows that the selected header has been correctly applied though.

Attachments (1)

1806.patch (1.3 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Cc: Jamal added

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: newassigned

This problem is caused by FCKEditingArea._EnsureFocusIE.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 1806.patch added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added

It seems that the IE behavior for the moveEnd function is not always predictable. I've changed that logic by using our current FCKDomRange.Select function, which already takes care of all IE's weirdnesses.

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1793]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy