Opened 11 years ago

Closed 7 years ago

#1826 closed Bug (worksforme)

link editor dialog and firefox 2.0.x

Reported by: Martin Adler Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: FireFox Cc:

Description

Descriptive summary

opening a link, the present href is not received by the link editor dialog, so it's like creating a new one.

Steps to reproduce

http://www.fckeditor.net/demo

  • please select the link "FCKEditor" and click the link icon in the toolbar
  • In the dialog the URL is empty on my Firefox configuration

Browser name and OS
FCKEditor 2.5.0 and 2.5.1:
Firefox 2.0.11 MacOSX 10.5: don't work
Firefox 2.0.9 WinXP SP2: don't work
IE6 and IE7 WinXP SP2: fine
Safari3 MacOSX 10.5: fine

FCKEditor 2.4.3:
Firefox 2.0.11 MacOSX 10.5 and FCKEditor 2.4.3: fine
Firefox 2.0.9 WinXP SP2 and FCKEditor 2.4.3: fine

So for me it seems to be a new 2.5.? specific problem?!?!?! I didn't find any information whether this was changed actively due to problems with Firefox in general, or this is a new bug of fckeditor?

Screenshot, Sample data, Test case file: not neccessary!

Change History (2)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed FF added
Version: FCKeditor 2.5.1

Confirmed in FF2. Apparently this bug has a strange behavior. If you put the cursor inside the link like: FCKedi|tor and than press the link button the info about the link will appear normally. It will also work when you will highlight text manually (from one side to another). The link properties doesn't work properly only when you highlight the text by clicking it twice. Than you can't find info about the link

comment:2 Changed 7 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible (if not done it already) since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy