Opened 11 years ago

Closed 6 years ago

#185 closed New Feature (wontfix)

.Value property vs .Text property

Reported by: anonymous Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version:
Keywords: SF Cc:

Description

I noticed the FCKeditorV2 dll uses the .Value property to represent the text in the textbox. This makes integrating the editor into existing applications difficult because I have to change all instances of myTextBox.Text to myTextBox.Value.

As far as the code-behind, it really should operate like a standard textbox.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1592309&group_id=75348&atid=543653

Change History (5)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Reporter: changed from Frederico Caldeira Knabben to anonymous

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Type: BugNew Feature

I agree that the .Text property wold be a good thing. We have used .Value because this is the name used in all other server side integrations. I believe we should make .Text an alias of .Value.

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Owner: Frederico Caldeira Knabben deleted

comment:4 Changed 9 years ago by Artur Formella

Keywords: Confirmed added

comment:5 Changed 6 years ago by kaga

Resolution: wontfix
Status: confirmedclosed

In new version CKEditora.NET property .Text is used.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy