Opened 11 years ago

Closed 11 years ago

#1859 closed Bug (fixed)

Floating dialog layout is broken on FF 3.0 beta 2.

Reported by: Martin Kou Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

The layout of floating dialogs are broken when opened in Firefox 3.0 beta 2. Specifically, the bottom button row is broken in FF3.

Attachments (2)

1859.patch (1.1 KB) - added by Martin Kou 11 years ago.
1859_2.patch (1.2 KB) - added by Frederico Caldeira Knabben 11 years ago.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by Martin Kou

Attachment: 1859.patch added

comment:1 Changed 11 years ago by Martin Kou

Keywords: Review? added

Took a while to figure out, but it's found to be due to an unneeded style attribute applied to the bottom button DIV.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Martin Kou to Frederico Caldeira Knabben

The removed "position: absolute" is needed to force the bottom area to stay at the bottom of the dialog. Your proposal seems to work because the top part of the dialog pushes the bottom are to the bottom. But, if there is a delay on loading the dialog contents (showing the throbber, for example), you will note that the bottom area will not be at the bottom if not "absolute".

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: 1859_2.patch added

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review- removed
Status: newassigned

The proposed patch ensures that the bottom area will fill the entire width available in the bottom. This one sounds like a FF3 bug though, as we don't have problems with FF2, Safari and Opera.

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review+ removed

Wrong keyword... again :)

comment:5 Changed 11 years ago by Martin Kou

Keywords: Review+ added; Review? removed

The updated patch works on all browsers I've tested and doesn't cause the button block to move up like the previous patch did. Review+.

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1523]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy