Opened 11 years ago

Closed 10 years ago

#1861 closed Bug (invalid)

Nested BODY tags

Reported by: Rob Ripberger Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Confirmed Pending Cc:

Description

If you have HTML content that contains a BODY tag with a BODY tag, only the content inside the inner tag is visible. For example:

<html> <BODY> <p>outer</p> <BR> <BODY> inner<BR> </BODY></BODY></HTML>

Only the "inner" text appears in the FCKeditor. This is needed because e-mail messages often have nested BODY tags.

Change History (4)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confimed added

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added; Confimed removed

comment:3 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Keywords: Pending added

That code is clearly invalid.

I don't understand why you say that "This is needed because e-mail messages often have nested BODY tags". If you send mails with invalid HTML then you are running the risk that the recipient will discard the content just like FCKeditor has done.

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Resolution: invalid
Status: newclosed

Expired

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy