Opened 10 years ago

Closed 7 years ago

#1864 closed Bug (worksforme)

[FF][Link][Tag]Switching to Source View adds P before and after link

Reported by: dense13 Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Cc:

Description

This is similar to ticket 926, but it involves adding a link, and it's present in the 2.5.1 demo.

I'm using Firefox 2.0.0.12 (Windows). It doesn't seem to happen with IE7 Win.

The steps to reproduce the problem:

  1. Select some text in the initial content of the demo.
  2. Click the 'link' button, add a url, and OK.
  3. Click the 'View source' button: the P tags have been added.

This only happens if it's the first thing I do. If before doing all that I first create a second paragraph (even just an empty one), and then add the link, the P tags are not added.

I tried it in the nightly build demo and it doesn't happen there. Then I downloaded the nightly build, and it's happening again in my local machine. Since I'm a bit confused, I thought I'd post a ticket. I apologize if this has already been solved or it's not actually a bug but a particular problem I'm having, I just wanted to let the developers know.

Change History (3)

comment:1 Changed 10 years ago by dense13

Btw, I've been trying with v2.5b, and it seems to work ok.

comment:2 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added
Summary: Switching to Source View adds P before and after link[FF][Link][Tag]Switching to Source View adds P before and after link
Version: FCKeditor 2.5.1

Confirmed in FF2. Works withe IE.

comment:3 Changed 7 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy