Opened 11 years ago

Closed 11 years ago

#1875 closed Bug (invalid)

Wrong compatibility check for gecko browsers.

Reported by: Thilo Schwarz Owned by:
Priority: Normal Milestone:
Component: Server : PHP Version:
Keywords: Cc:

Description

The compatibility check in http://dev.fckeditor.net/browser/FCKeditor/releases/stable/fckeditor.php is wrong. You check for gecko>=20030210, but for example firefox 1.0.3 has 20050414 and would pass the check. Sorry I don't know the exact version number to check for. Because you have to respect other gecko-based browsers too. But 20030210 is definitively much to less.

A good place for looking for user agent strings: http://www.useragentstring.com/

Change History (3)

comment:1 Changed 11 years ago by Alfonso Martínez de Lizarrondo

checking the build date isn't correct, but there are some details:

The check for gecko is for Mozilla 1.3, not Firefox 1.0.3, all Firefox versions are compatible, so the 2005 date is perfectly valid.

As noted in http://dev.fckeditor.net/browser/FCKeditor/trunk/editor/_source/internals/fckbrowserinfo.js the check should be done on the rv: part, but it will need to be tested that all Gecko based browsers do report properly that part.

comment:2 Changed 11 years ago by Thilo Schwarz

Ok, sorry, I see, I'm wrong! I just thought we supported Firefox >= 1.5! Sorry for this report and thanks for clar1ify.

comment:3 Changed 11 years ago by Wojciech Olchawa

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy