Opened 11 years ago

Closed 11 years ago

#1889 closed Bug (duplicate)

Switching between source view and normal causes attributes to swap (Gecko)

Reported by: rekcor Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Confirmed Cc:

Description

For example:

<img src="a.gif" alt="b />

becomes

<img alt="b src="a.gif" />

when switching two times between normal view and normal view.

This is undesirable behavior, because e.g. user defined regular expressions become unreliable.

The bug is caused by the function FCKXHtml._AppendAttributes in fckxhtml_gecko.js, where it says

for ( var n = 0 ; n < aAttributes.length ; n++ )

which should become:

for ( var n = aAttributes.length-1 ; n >= 0; n-- )

See also http://www.fckeditor.net/forums/viewtopic.php?f=5&t=4987

Change History (2)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added; attributes swap removed

Confirmed in FF2, but Safari/Win and Opera 9.5 beta have different results.

In Safari 3.0.4 the code just vanishes.

In Opera 9.50 beta and in IE the code is transformed to normal text.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: newclosed

DUP of #1810

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy