Opened 11 years ago

Closed 11 years ago

#1898 closed Bug (fixed)

Domain relaxation is broken for floating dialogs

Reported by: Martin Kou Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Review+ Cc:

Description

This is a regression bug.

To reproduce:

  1. Modify sample01.html so that it runs in domain relaxation mode.
  2. Open the modified sample01.html.
  3. Open a dialog, e.g. the smiley dialog.
  4. Permission denied errors.

Attachments (2)

1898_pre.patch (1.9 KB) - added by Martin Kou 11 years ago.
1898.patch (1.3 KB) - added by Martin Kou 11 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by Martin Kou

Summary: Domain relaxation is brokenDomain relaxation is broken for floating dialogs

comment:2 Changed 11 years ago by Martin Kou

Another related bug found. If you open and close the image dialog under domain relaxation mode in IE6 will crash the browser.

comment:3 Changed 11 years ago by Wojciech Olchawa

Cc: Confirmed IE removed
Keywords: Confirmed IE added

Wrong field for Confirmed :)

I will just move the keywords. :)

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

As proposed by Alfonso, it seems it is enough to move the domain fixing code at the top of fckdialog.html, before the "var E" declaration.

comment:5 in reply to:  4 Changed 11 years ago by Martin Kou

Replying to fredck:

As proposed by Alfonso, it seems it is enough to move the domain fixing code at the top of fckdialog.html, before the "var E" declaration.

I've done that the first moment I found the bug, but it doesn't fix the IE crash issue.

The IE crash bug is really nasty. It happens with any dialog with a preview pane, i.e. the image dialog, the flash dialog and the image button dialog. The symptom is... you open the dialog, and close it, then IE crashes and would be forced to be closed by Windows. This is a very severe bug as it causes data loss and makes the three dialogs unusable.

The IE crash occurs as long as there is a <script> tag, even an empty one, in the preview pane's HTML. It occurs in IE6 only, and does not occur in IE7.

Changed 11 years ago by Martin Kou

Attachment: 1898_pre.patch added

comment:6 Changed 11 years ago by Martin Kou

Keywords: Review? added

Proposed patch to fix the permission denied error and the IE6 crash issue. Some other less critical errors have been found for domain relaxation mode in these few days, but those are less critical and they can be fixed after tomorrow's Beta 1 release.

comment:7 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

Please move the dialog crash fix to a dedicated ticket.

Also, for line 194, the following seems to be enough:

setTimeout( function(){ topDialog = null ; }, 0 ) ; 

Changed 11 years ago by Martin Kou

Attachment: 1898.patch added

comment:8 Changed 11 years ago by Martin Kou

Keywords: Review? added; Review- removed

A new ticket, #1918, has been opened for the IE crash issue.

comment:9 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:10 Changed 11 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [1611].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy