Opened 11 years ago

Closed 10 years ago

#1917 closed Bug (fixed)

mergedown error / three cell

Reported by: Jaedeok Seol Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE HasPatch Review+ Cc:

Description

two cell mergedown ok! three cell mergedown table broken.

Attachments (2)

fcktablehandler.js.patch (1.2 KB) - added by Karen Ananiev 10 years ago.
1917.patch (1.6 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Pending added

Hi!

Could you please provide more detailed information about the bug? Also, could you please let us know what kind of browser and what version of FCKeditor are you using.

Thanks.

comment:2 Changed 11 years ago by Martin Kou

Keywords: Confirmed IE added; Pending removed

Confirmed.

To reproduce the bug, open sample01.html in IE.

  1. Make a 2x3 table which is the default.
  2. Right click on a cell in the top, choose cells, merge down.
  3. Right click on the merged cell, choose again cells, merge down.
  4. The table becomes broken.

Merging in Firefox works.

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.7

comment:4 Changed 11 years ago by Martin Kou

#1941 marked as a dup of this ticket.

comment:5 Changed 11 years ago by Martin Kou

#2055 marked as a dup of this ticket.

comment:6 Changed 10 years ago by Julia

I'm interested in.

Changed 10 years ago by Karen Ananiev

Attachment: fcktablehandler.js.patch added

comment:7 Changed 10 years ago by Martin Kou

Keywords: HasPatch added
Milestone: FCKeditor 2.6.3
Version: SVN

comment:8 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:9 Changed 10 years ago by Martin Kou

Keywords: Review? added

Lines 733 and 734 from Karena's patch isn't really needed because we're counting the rowSpan from the tableMap data structure, so we don't really have to add up the rowSpan of the current cell if we've already stored the sum in another variable.

Karena's patch has worked around an IE bug here though, which is the essential component of the fix. Our current code does not work in IE because we're depending on IE reporting the correct rowSpan for the td elements - unfortunately when a td is not attached to a tr IE would always report its rowSpan to be 1. So Karena's way of storing the sum in a variable works around the problem.

Proposing a new patch with lines 733 and 734 from Karena's patch removed.

Changed 10 years ago by Martin Kou

Attachment: 1917.patch added

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:11 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2158].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy