Opened 12 years ago

Closed 12 years ago

#196 closed Bug (invalid)

Ver 2.4: 'FCKlang' is not defined ... Editor not appear in IE

Reported by: Muja Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: Cc:

Description

This happened when using IE6 for some of my users (not all). Cleared cached, problem still persist.

Firefox no problem.

Attachments (1)

fckconfig.js (11.2 KB) - added by Muja 12 years ago.
This is my fckconfig.js

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Muja

Attachment: fckconfig.js added

This is my fckconfig.js

comment:1 Changed 12 years ago by anonymous

yeah, i got the same error in IE. Any solution?

comment:2 Changed 12 years ago by Muja

i found out that i wrongly delete a segment of a line in fckeditor.html to be the cause of this problem. Once restored to the original, all work fine.

For the record, this was what i tried to do (I wanted to hide any error message especially when refreshing a page while editor is still loading):

function LoadScript( url )
{
//	document.write( '<script type="text/javascript" src="' + url + '" onerror="alert(\'Error loading \' + this.src);"><\/script>' ) ;
	document.write( '<script type="text/javascript" src="' + url + '" ><\/script>' ) ;   // Remove annoying error msg

}

function LoadCss( url )
{
//	document.write( '<link href="' + url + '" type="text/css" rel="stylesheet" onerror="alert(\'Error loading \' + this.src);" />' ) ;
	document.write( '<link href="' + url + '" type="text/css" rel="stylesheet" " />' ) ; // Remove annoying error msg

}

You can consider to close this ticket. Thank you and sorry for any inconvenience caused.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed

Yes, such kinds of issues happen for customization in the code, generally. Usually, the error message has nothing to do with the real error, but its a symptom of it. Possibly more than one error is thrown, and just one of them is the real error.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy